Community forum

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
View
Go to last post Go to first unread
Offline Burak Akkor  
#1 Posted : Thursday, January 8, 2015 3:04:41 PM(UTC)
Burak Akkor

Rank: No customer

Joined: 12/8/2014(UTC)
Posts: 1

Hello,

I'm using 7.5.1 and I have a question.

Basically I want to pass variables to job and trigger it.

Here is the sample;

Code:

using System;
using VisualCron;
using VisualCronAPI;

public class Test
{
 public static string TestTrigger(string jobId)
 {
  List<global::VisualCron.JobVariableClass> variables = new List<global::VisualCron.JobVariableClass>();
  variables.Add(new global::VisualCron.JobVariableClass() { Key = "Triggered", ValueObject = System.Text.Encoding.Default.GetBytes("test@test.com") });
  VisualCronServer.Jobs.Run(jobId, bolCheckConditions: true, bolSynchrous: true, lstJobVariables: variables, bolUpdateJobVariables: false);
 }
}


But this is not working actually or am I doing something wrong? I don't want to add or update job variables which I can easily do that through API. I just want to send my dynamic variables to task and trigger it with one time variables.

When I try to get that variable value from VC like {JOB(Active,Variable,Triggered)} is returns to me not found.

And secondly what encoding type is using in VC variables?

Thanks already,
Burak

Edited by user Thursday, January 8, 2015 7:18:22 PM(UTC)  | Reason: Not specified

Users browsing this topic
Guest
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF.NET | YAF.NET © 2003-2016, Yet Another Forum.NET
This page was generated in 0.134 seconds.
Scroll to Top