Client Login fails - VisualCron - Forum

Community forum

lal
  •  lal
  • No customer Topic Starter
2008-06-24T06:51:21Z
The VisualCron client is installed on multiple workstations, and there are multiple VisualCron servers to connect to. The VisualCron client on one workstation (not all of them), regardless of the VC user ID that is used, gets an error when trying to connect to one particular server (not all of them.)

"could not parse server message. are you connecting to an old server version of VC?" If "OK" on this message is clicked, then the client disconnects.

Originally, the client was on 4.9.1 - did an upgrade to 4.9.3, to match the server version, but this had no effect.

Looking at the server log, the sequence of messages is as follows:


On initial connection:

6/23/2008 11:11:20 PM Info User "User Name" - Logged in succesfully through Socket (e0eeacb1-2f7c-4a73-93df-168b1ea109df)
6/23/2008 11:11:20 PM Debug Updating login status for: e0eeacb1-2f7c-4a73-93df-168b1ea109df
6/23/2008 11:11:20 PM Comm IN: SERVERSETTINGSREQ
6/23/2008 11:11:20 PM Comm IN: LICENSEREQ
6/23/2008 11:11:20 PM Comm IN: LOGINFOREQ
6/23/2008 11:11:20 PM Comm IN: USERSREQ
6/23/2008 11:11:20 PM Comm IN: NCREQ

When "ok" is clicked on the error message:

6/23/2008 11:13:14 PM Debug New client connected.
6/23/2008 11:13:14 PM Debug Before returning sslStream
6/23/2008 11:13:14 PM Debug AuthenticateAsServer, certificate name: CN=vc
6/23/2008 11:13:14 PM Debug AuthenticateAsServer doneCN=vc
6/23/2008 11:13:14 PM Debug Client: e0eeacb1-2f7c-4a73-93df-168b1ea109df (IP Address) has disconnected

Any ideas on how to fix this?

Support
2008-06-24T07:22:14Z
Hmm..

1. What is special about that workstation?

2. Have your run all Windows updates on the client machine?

3. Do you have a secur32.dll in your VisualCron folder?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
lal
  •  lal
  • No customer Topic Starter
2008-06-24T10:07:30Z
1) The workstations with the VC client have a standard build.
2) Yes, the windows updates are up-to-date, with the exception of SP3 for XP, which has not yet been authorized for installation.
3) No, it does not have the secur32.dll file; however, neither do the other workstations, which have been working ok?

By the way, this workstation connection to this server has worked in the past, and there have not been changes to the VC Client since it last worked.
Support
2008-06-24T12:39:37Z
Can you verify, if you examine the files VisualCronClient.exe and VisualCron.dll, that they have the same build on all clients (compare one working with the non-working).
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Scroll to Top