Unable to restart stopped VisualCron Service port already registered - VisualCron - Forum

Community forum

ahazelwood
2015-03-12T12:15:14Z
Recently the VisualCron service (7.6.1) crashed. In the process of restarting it, I keeps getting the following error. The only solution so far is to restart the Server.
Thanks.

3/12/2015 8:10:02 AM Debug Assembly loaded: System.Xml, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
3/12/2015 8:10:02 AM Debug Starting up
3/12/2015 8:10:02 AM Debug Loading settings
3/12/2015 8:10:02 AM Debug Assembly loaded: System.Configuration, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
3/12/2015 8:10:02 AM Debug Assembly loaded: Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
3/12/2015 8:10:02 AM Debug Assembly loaded: ZetaLongPaths, Version=1.0.0.4, Culture=neutral, PublicKeyToken=b764f59068f31f38
3/12/2015 8:10:03 AM Debug Preparing SqlCe files (x64) from base folder: C:\Program Files (x86)\VisualCron\x64\sqlce
3/12/2015 8:10:03 AM Debug Assembly loaded: System.Data.SqlServerCe, Version=4.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91
3/12/2015 8:10:03 AM Debug Assembly loaded: System.Data, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
3/12/2015 8:10:03 AM Debug Assembly loaded: System.Transactions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
3/12/2015 8:10:03 AM Debug Assembly loaded: System.EnterpriseServices, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
3/12/2015 8:10:04 AM Debug Assembly loaded: SecureBlackbox.HTTP, Version=12.0.265.0, Culture=neutral, PublicKeyToken=2da58450a50132f5
3/12/2015 8:10:04 AM Debug Assembly loaded: SecureBlackbox, Version=12.0.265.0, Culture=neutral, PublicKeyToken=2da58450a50132f5
3/12/2015 8:10:04 AM Debug Assembly loaded: InteractiveLogonComponent, Version=1.0.0.35725, Culture=neutral, PublicKeyToken=null
3/12/2015 8:10:04 AM Debug Assembly loaded: SevenZipSharp, Version=0.64.5409.24501, Culture=neutral, PublicKeyToken=null
3/12/2015 8:10:04 AM Debug Assembly loaded: WindowsBase, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
3/12/2015 8:10:04 AM Debug Prepare XML writer settings
3/12/2015 8:10:04 AM Debug 7Zip library path: C:\Program Files (x86)\VisualCron\7z64.dll
3/12/2015 8:10:04 AM Debug Current user: NT AUTHORITY\SYSTEM
3/12/2015 8:10:04 AM Debug Create directories
3/12/2015 8:10:04 AM Debug Assembly loaded: System.Management, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
3/12/2015 8:10:04 AM Debug Output folder: C:\ProgramData\VisualCron\output
3/12/2015 8:10:04 AM Debug Startup function called
3/12/2015 8:10:04 AM Info Current user: DC-CIRADAR\SYSTEM
3/12/2015 8:10:04 AM Info OS version: Windows8ServerDeveloperPreview
3/12/2015 8:10:04 AM Info Credential provider->Prepare interaction
3/12/2015 8:10:04 AM Info Is Vista or higher: True
3/12/2015 8:10:05 AM Info Credential provider->Credential provider was already installed.
3/12/2015 8:10:05 AM Debug Credential provider->Credential provider failed: ControlAltDeleteDisabled is false. Need to be set to true.
3/12/2015 8:10:05 AM Info VisualCron - Server: 7.6.1 - build: 35737(2015-03-02 13:51:16) - protocol: 7.5.2
3/12/2015 8:10:05 AM Debug Startup path: C:\Program Files (x86)\VisualCron
3/12/2015 8:10:05 AM Debug Loading license file
3/12/2015 8:10:05 AM Debug Assembly loaded: Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
3/12/2015 8:10:05 AM Debug License file was successfully loaded
3/12/2015 8:10:05 AM Debug Saving license file
3/12/2015 8:10:05 AM Debug License file was saved successfully
3/12/2015 8:10:05 AM Debug Successful verification of Activation code
3/12/2015 8:10:05 AM Info License status: Activated
3/12/2015 8:10:05 AM Debug Assembly loaded: Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
3/12/2015 8:10:05 AM Debug Loading language
3/12/2015 8:10:05 AM Debug Assembly loaded: Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
3/12/2015 8:10:05 AM Debug API->Calling InitMonths
3/12/2015 8:10:05 AM Debug API->Calling InitDays
3/12/2015 8:10:05 AM Debug API->Calling InitMonths
3/12/2015 8:10:05 AM Debug API->Calling InitDays
3/12/2015 8:10:05 AM Debug Assembly loaded: System.Numerics, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
3/12/2015 8:10:06 AM Debug Loading exit codes
3/12/2015 8:10:06 AM Debug Assembly loaded: Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
3/12/2015 8:10:06 AM Debug Loaded: 0 exit code collection(s)
3/12/2015 8:10:06 AM Debug DefaultPersistentConnectionLimit: 2
3/12/2015 8:10:06 AM Debug Assembly loaded: System.ServiceModel, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
3/12/2015 8:10:06 AM Debug Assembly loaded: SMDiagnostics, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
3/12/2015 8:10:06 AM Debug Assembly loaded: System.ServiceModel.Internals, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
3/12/2015 8:10:06 AM Debug Assembly loaded: System.ServiceModel.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
3/12/2015 8:10:06 AM Debug Assembly loaded: System.Runtime.Serialization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
3/12/2015 8:10:06 AM Debug Assembly loaded: System.IdentityModel, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
3/12/2015 8:10:06 AM Debug Loading Variables
3/12/2015 8:10:06 AM Debug Assembly loaded: Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
3/12/2015 8:10:06 AM Info Loaded: 0 Variable(s)
3/12/2015 8:10:06 AM Debug Loading Certificates
3/12/2015 8:10:06 AM Debug Assembly loaded: Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
3/12/2015 8:10:06 AM Info Loaded: 0 Certificates(s)
3/12/2015 8:10:06 AM Debug Loading connections
3/12/2015 8:10:06 AM Debug Assembly loaded: Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
3/12/2015 8:10:06 AM Info Loaded: 0 FTP connection(s)
3/12/2015 8:10:06 AM Debug Loading Groups
3/12/2015 8:10:06 AM Debug Assembly loaded: Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
3/12/2015 8:10:06 AM Debug Assembly loaded: System.DirectoryServices, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
3/12/2015 8:10:06 AM Info Loaded: 3 groups(s)
3/12/2015 8:10:06 AM Debug Loading users
3/12/2015 8:10:06 AM Debug Assembly loaded: Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
3/12/2015 8:10:06 AM Info Loaded: 1 users(s)
3/12/2015 8:10:07 AM Debug Loading Conditions
3/12/2015 8:10:07 AM Debug Assembly loaded: Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
3/12/2015 8:10:07 AM Info Loaded: 0 Condition(s)
3/12/2015 8:10:07 AM Debug Loading PGP Key Rings
3/12/2015 8:10:07 AM Debug Assembly loaded: Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
3/12/2015 8:10:07 AM Info Loaded: 0 PGP Key Ring(s)
3/12/2015 8:10:07 AM Debug Loading Time Exceptions
3/12/2015 8:10:07 AM Debug Assembly loaded: Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
3/12/2015 8:10:07 AM Info Loaded: 0 time exception(s)
3/12/2015 8:10:07 AM Debug Loading network credentials
3/12/2015 8:10:07 AM Debug Assembly loaded: Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
3/12/2015 8:10:07 AM Debug Loaded: 0 network credential(s)
3/12/2015 8:10:07 AM Debug Loading TaskNotifications
3/12/2015 8:10:07 AM Debug Assembly loaded: Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
3/12/2015 8:10:11 AM Info Loaded: 0 TaskNotifications(s)
3/12/2015 8:10:11 AM Debug Loading Network Drives
3/12/2015 8:10:11 AM Debug Assembly loaded: Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
3/12/2015 8:10:11 AM Info 0 network drive(s) were loaded
3/12/2015 8:10:11 AM Debug Exiting NetworkDrivesAPI.Load
3/12/2015 8:10:11 AM Debug Loading jobs
3/12/2015 8:10:12 AM Debug Assembly loaded: Microsoft.GeneratedCode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
3/12/2015 8:10:16 AM Info Loaded: 0 job(s)
3/12/2015 8:10:16 AM Debug Expiring old triggers
3/12/2015 8:10:16 AM Info Searching for jobs that should have been executed
3/12/2015 8:10:16 AM Info Running missed jobs between 3/11/2015 11:45:25 PM and 3/12/2015 8:10:16 AM
3/12/2015 8:10:16 AM Debug Recalculating all jobs
3/12/2015 8:10:16 AM Debug Starting main threads
3/12/2015 8:10:16 AM Debug InternalWorkerThreadClass was started
3/12/2015 8:10:16 AM Debug Flushing memory
3/12/2015 8:10:16 AM Debug Startup finished
3/12/2015 8:10:16 AM Debug Assembly loaded: System.Web.Services, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
3/12/2015 8:10:16 AM Debug Assembly loaded: System.Net.Http, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
3/12/2015 8:10:16 AM Debug Assembly loaded: CommServer, Version=1.0.0.0, Culture=neutral, PublicKeyToken=55f7a52402de1c04
3/12/2015 8:10:16 AM Debug Assembly loaded: CommClientCore, Version=1.0.0.0, Culture=neutral, PublicKeyToken=55f7a52402de1c04
3/12/2015 8:10:16 AM Debug Starting CommServer.
3/12/2015 8:10:16 AM Debug ComService (WCFService) registered in: net.tcp://0.0.0.0:16444/
3/12/2015 8:10:17 AM Debug ComService stopped.
3/12/2015 8:10:17 AM Debug Startup failed, ex: System.ServiceModel.AddressAlreadyInUseException: There is already a listener on IP endpoint 0.0.0.0:16444. This could happen if there is another ap
plication already listening on this endpoint or if you have multiple service endpoints in your service host with the same IP endpoint but with incompatible binding configurations. ---> System.Net.Sock
ets.SocketException: Only one usage of each socket address (protocol/network address/port) is normally permitted
at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)
at System.Net.Sockets.Socket.Bind(EndPoint localEP)
at System.ServiceModel.Channels.SocketConnectionListener.Listen()
--- End of inner exception stack trace ---
at System.ServiceModel.Channels.SocketConnectionListener.Listen()
at System.ServiceModel.Channels.ConnectionAcceptor.StartAccepting()
at System.ServiceModel.Channels.ExclusiveTcpTransportManager.OnOpen()
at System.ServiceModel.Channels.TransportManager.Open(TransportChannelListener channelListener)
at System.ServiceModel.Channels.TransportManagerContainer.Open(SelectTransportManagersCallback selectTransportManagerCallback)
at System.ServiceModel.Channels.TcpChannelListener`2.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Dispatcher.ChannelDispatcher.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.ServiceHostBase.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at CommServer.Classes.WCF.WCFService.Start()
at CommServer.Classes.Server.Initialize(ServerConfiguration configuration)
at OBOKIIHBDBPMCFALPGECCIFHCDJPEDKODDGK.KKEJOPBHMHJAFFFPKGJBEKICKOPHECFAFHBI.EKKOHMNKJBKFLBFIDMJLBEAHLJBODNFACDHI() in C:\sourcefiles\code\VisualCronService\Connection\clsCommServer.vb:line 53
at OBOKIIHBDBPMCFALPGECCIFHCDJPEDKODDGK.BFKKBFHNMCPNGKDAMGHAALAAGFILDGDNGLPK.ECOCPICIJKFIEJFNFHIHBEAMNMHOJOCFLGKH() in C:\sourcefiles\code\VisualCronService\Connection\apiConnection.vb:line 483
at OBOKIIHBDBPMCFALPGECCIFHCDJPEDKODDGK.JMCCOOPHNCFNEHPADILOIKGCFNHNAEBKLCAJ.INHDDLNHOPEJBEJNJDFIHAIBMCAIFOMNEJOO() in C:\sourcefiles\code\VisualCronService\Main\modMain.vb:line 678
at OBOKIIHBDBPMCFALPGECCIFHCDJPEDKODDGK.LAFDMIGCFJJDFILBNNFAJJEAPPONBLLEBDMK.EKKOHMNKJBKFLBFIDMJLBEAHLJBODNFACDHI() in C:\sourcefiles\code\VisualCronService\Main\clsStartup.vb:line 8
Support
2015-03-12T12:55:49Z
Thanks for the feedback - we will try to reproduce this. Could you send log_serverDATE.txt to support@visualcron.com and tell us which time the service crashed approximately?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
twagner
2015-03-12T20:18:45Z
I have experienced this as well after upgrading to 7.61.

If I attempted to view the server log with debugging turned on it would crash the server service and I could not restart the server service without restarting the server itself. Since i disabled debugging I don't get the crash.
ahazelwood
2015-03-12T21:30:42Z
Here are the requested files from the specific server. Once I restarted it twice, the issue seems to have gone away. But I had noticed it periodically happening over the last few days.
File Attachment(s):
VisualCron.zip (123kb) downloaded 39 time(s).
Support
2015-03-12T23:54:55Z
Originally Posted by: ahazelwood 

Here are the requested files from the specific server. Once I restarted it twice, the issue seems to have gone away. But I had noticed it periodically happening over the last few days.



Around 8AM in the log file it seems like it was restarted many times. Did you restart it manually or? Do you have any errors in the event log at that time?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
ahazelwood
2015-03-13T15:11:38Z
I restarted it in an attempt to get it running. At the end I finally restarted the server. Also on those servers we have a scheduled windows task using powershell that will check every 5 minutes to see if the VisualCron Service is running and if not, it will start it again.
Scroll to Top