Server.Permissions.GetUserName does not return user name - VisualCron - Forum

Community forum

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
View
Go to last post Go to first unread
Offline Tjomme  
#1 Posted : Wednesday, June 14, 2017 12:49:46 PM(UTC)
Tjomme

Rank: Free support

Joined: 11/13/2015(UTC)
Posts: 10
Belgium
Location: Brussels Hoofdstedelijk Gewest, Brussels

Hi,

we're working with VisualCron 8.2.4

Working with the API and VB .NET, I'm trying to get the user name as listed in the user permissions window.
According to the documentation this should be done by calling Server.Permissions.GetUserName(UserID).
However, this returns the Name instead.

Is this a bug or should I use another function?

Thanks,
Tjomme

Edited by moderator Wednesday, June 14, 2017 4:22:25 PM(UTC)  | Reason: Not specified

Offline Support  
#2 Posted : Wednesday, June 14, 2017 4:22:03 PM(UTC)
Support

Rank: Official support

Joined: 2/23/2008(UTC)
Posts: 11,258

Thanks: 877 times
Was thanked: 450 time(s) in 427 post(s)
Yes, we think it is a bug. The actual Name should be recieved from GetFullUserName. We have fixed this for the next build.

Workaround would be to;

Code:
serverObj.Decrypt(userObject.UserName);
Henrik
Support
http://www.visualcron.com
Please like VisualCron on facebook!
Offline Tjomme  
#3 Posted : Thursday, June 15, 2017 4:31:08 PM(UTC)
Tjomme

Rank: Free support

Joined: 11/13/2015(UTC)
Posts: 10
Belgium
Location: Brussels Hoofdstedelijk Gewest, Brussels

Thanks!

The workaround works.

Tjomme
Users browsing this topic
Guest
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Scroll to Top