Community forum

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
View
Go to last post Go to first unread
Offline bweston  
#1 Posted : Thursday, December 13, 2018 4:28:21 PM(UTC)
bweston

Rank: Paid support

Joined: 12/14/2012(UTC)
Posts: 76

Thanks: 2 times
Was thanked: 15 time(s) in 13 post(s)
Since updating to 8.4.0, I can browse Dropbox using the explorer, but my download task and the "list files" tab when editing it get

Quote:
Exception in Task: Unable to cast object of type 'SBDropboxDataStorage.TElDropboxDataStorageFolder' to type 'SBDropboxDataStorage.TElDropboxDataStorageFile'.


I tried recreating the connection, the task, and then the job. Same result.

Even with extra debugging enabled on the task, all I see in the log is

Quote:
12/13/2018 10:25:23 AM Info Task started(Download file(s)): Download file(s) (16244915)
12/13/2018 10:25:25 AM Info Task completed (Failure)->'Download file(s)' (16244915)


Any help for this? Is it me? For now I'm going to download manually as I really do not want to downgrade.
Offline Support  
#2 Posted : Thursday, December 13, 2018 4:39:11 PM(UTC)
Support

Rank: Official support

Joined: 2/23/2008(UTC)
Posts: 11,059

Thanks: 851 times
Was thanked: 431 time(s) in 409 post(s)
I think this issue has been fixed in 8.4.1. Are you able to verify this? https://www.visualcron.c....aspx?g=posts&t=9226
Henrik
Support
http://www.visualcron.com
Please like VisualCron on facebook!
Offline bweston  
#3 Posted : Tuesday, December 18, 2018 10:57:01 PM(UTC)
bweston

Rank: Paid support

Joined: 12/14/2012(UTC)
Posts: 76

Thanks: 2 times
Was thanked: 15 time(s) in 13 post(s)
That does seem to be the case.

Accessing the job variables of one job from another job doesn't seem to work the same way it used to, but that is a separate problem.
Offline Support  
#4 Posted : Wednesday, December 19, 2018 9:49:30 AM(UTC)
Support

Rank: Official support

Joined: 2/23/2008(UTC)
Posts: 11,059

Thanks: 851 times
Was thanked: 431 time(s) in 409 post(s)
Originally Posted by: bweston Go to Quoted Post
That does seem to be the case.

Accessing the job variables of one job from another job doesn't seem to work the same way it used to, but that is a separate problem.


I am not sure of this reply. It was originally about Download issue. Can you confirm it works?

What is the problem with Variables?
Henrik
Support
http://www.visualcron.com
Please like VisualCron on facebook!
Offline bweston  
#5 Posted : Wednesday, January 9, 2019 10:20:44 PM(UTC)
bweston

Rank: Paid support

Joined: 12/14/2012(UTC)
Posts: 76

Thanks: 2 times
Was thanked: 15 time(s) in 13 post(s)
Sorry, I didn't see this reply before.

The download issue is resolved in the 8.4.1 beta; however, I had some other jobs that stopped working correctly due to what appeared to be an inability to use job variables of one job in the tasks of another job (which had previously worked). I did not have time to investigate more thoroughly due to a major deadline coming up this month, so I ended up just copying the job variables to the dependent job and moving on. The comment I made here was meant to imply that if I couldn't identify that issue has having somehow arisen from something I did, I would report it as a separate problem. I haven't had time to do that, either, though.
Users browsing this topic
Guest
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Scroll to Top