7.2.1 - VisualCron - Forum

Community forum

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
View
Go to last post Go to first unread
Offline Support  
#1 Posted : Monday, September 1, 2014 2:53:56 PM(UTC)
Support

Rank: Official support

Joined: 2/23/2008(UTC)
Posts: 11,258

Thanks: 877 times
Was thanked: 450 time(s) in 427 post(s)
The following changes has been made so far:

[FEATURE] Client/Server: SSIS Task->Added support for MSSQL 2014 SSIS package execution
[FEATURE] Client/Server: Added Task->Amazon EC2 - Create snapshot
[FEATURE] Client/Server: Added Task->Amazon EC2 - List snapshots
[FEATURE] Client/Server: Added Task->Amazon EC2 - Delete snapshot
[FEATURE] Client/Server: Added Task->Amazon EC2 - List addresses
[FEATURE] Client/Server: Added Task->Amazon EC2 - List key pairs
[FEATURE] Client/Server: Added Task->Amazon EC2 - List security groups
[FEATURE] Client/Server: Added Task->Amazon EC2 - List volumes
[FEATURE] Client/Server: Added Task->Amazon EC2 - Reboot instance
[FEATURE] Client/Server: Added Task->Amazon EC2 - Start instance
[FEATURE] Client/Server: Added Task->Amazon EC2 - Stop instance
[FEATURE] Client/Server: Added Task->Amazon EC2 - Terminate instance
[FEATURE] Client/Server: Added Task->Amazon EC2 - List instances
[BUGFIX] Client/Server: Popup Task->Fixed input handling problem with radio boxes
[BUGFIX] Server: Fixed a problem with renaming strings which could come up in different Task types
[BUGFIX] Server: Dynamics CRM general->Fixed a general returning description for some entity types
[BUGFIX] API: Fixed issue with Adding/Updating Job Variables
[BUGFIX] Client: Loops->Fixed resizing error in window
[BUGFIX] Server: Email Task/Notification->Fixed error "User authentication failed: No SASL mechanisms supported by both the client and the server (error code is 0)"
[BUGFIX] Client: Desktop Macro Task->Fixed a problem which could occur when saving the macro
[BUGFIX] Server: Fixed a small database cleanup issue
[BUGFIX] Server: FTP Task->Fixed Copy/Move files sub folders issue

Edited by user Wednesday, September 17, 2014 3:18:13 PM(UTC)  | Reason: Not specified

Henrik
Support
http://www.visualcron.com
Please like VisualCron on facebook!
Offline KJDavie  
#2 Posted : Wednesday, September 3, 2014 12:24:46 AM(UTC)
KJDavie

Rank: No customer

Joined: 9/25/2012(UTC)
Posts: 106
Australia
Location: Brisbane,Qld

Thanks: 17 times
Was thanked: 41 time(s) in 27 post(s)
Hi Henrik,

You should be getting some client crash emails from me, please let me know if they don't come through with the details you need.

Haven't been able to correlate to a particular client action from me, seems to occur even in an idle client.

This seems to occur also in 7.2.0 Released (Current Testing is on the 7.2.1 Beta).

I have not observed this behaviour in the 7.1.9 Client.

Edited by user Wednesday, September 3, 2014 12:38:31 AM(UTC)  | Reason: Additional Details

File Attachment(s):
20140903 XML Document Error.txt (2kb) downloaded 45 time(s).
Offline Support  
#3 Posted : Wednesday, September 3, 2014 1:03:31 PM(UTC)
Support

Rank: Official support

Joined: 2/23/2008(UTC)
Posts: 11,258

Thanks: 877 times
Was thanked: 450 time(s) in 427 post(s)
Originally Posted by: KJDavie Go to Quoted Post
Hi Henrik,

You should be getting some client crash emails from me, please let me know if they don't come through with the details you need.

Haven't been able to correlate to a particular client action from me, seems to occur even in an idle client.

This seems to occur also in 7.2.0 Released (Current Testing is on the 7.2.1 Beta).

I have not observed this behaviour in the 7.1.9 Client.


Is Client and Server of same version?
Henrik
Support
http://www.visualcron.com
Please like VisualCron on facebook!
Offline Support  
#4 Posted : Wednesday, September 3, 2014 1:04:42 PM(UTC)
Support

Rank: Official support

Joined: 2/23/2008(UTC)
Posts: 11,258

Thanks: 877 times
Was thanked: 450 time(s) in 427 post(s)
New build, changes:

[BUGFIX] Server->Dynamis CRM general->Fixed a general returning description for some entity types
[BUGFIX] API->Fixed issue with Adding/Updating Job Variables
Henrik
Support
http://www.visualcron.com
Please like VisualCron on facebook!
Offline KJDavie  
#5 Posted : Wednesday, September 3, 2014 10:36:42 PM(UTC)
KJDavie

Rank: No customer

Joined: 9/25/2012(UTC)
Posts: 106
Australia
Location: Brisbane,Qld

Thanks: 17 times
Was thanked: 41 time(s) in 27 post(s)
Hi Henrik,

Not always.

Client has been either 7.2.0 Released or 7.2.1 Beta
Initial Testing has matching Client and Server Versions.
Servers (Production) are 7.1.6.

So Test is aligned (Client and Server) but we also test against our production version, as long as the Protocol is compatible.

As we have discussed previously, deploying across a number of servers when the protocol changes enforces a much more compressed schedule of rollout.

Both are listed Protocol 7.0.0 ? but perhaps there is an inconsistency here ?

We are intending to upgrade servers soon, perhaps sooner than we think !

Thanks

Kevin

Edited by user Wednesday, September 3, 2014 11:03:13 PM(UTC)  | Reason: Additional Details

Offline Support  
#6 Posted : Thursday, September 4, 2014 9:23:26 AM(UTC)
Support

Rank: Official support

Joined: 2/23/2008(UTC)
Posts: 11,258

Thanks: 877 times
Was thanked: 450 time(s) in 427 post(s)
Originally Posted by: KJDavie Go to Quoted Post
Hi Henrik,

Not always.

Client has been either 7.2.0 Released or 7.2.1 Beta
Initial Testing has matching Client and Server Versions.
Servers (Production) are 7.1.6.

So Test is aligned (Client and Server) but we also test against our production version, as long as the Protocol is compatible.

As we have discussed previously, deploying across a number of servers when the protocol changes enforces a much more compressed schedule of rollout.

Both are listed Protocol 7.0.0 ? but perhaps there is an inconsistency here ?

We are intending to upgrade servers soon, perhaps sooner than we think !

Thanks

Kevin


Normally there should not be a problem. We really try to be backwards compatible but sometimes we need to cleanup/change some things.

Henrik
Support
http://www.visualcron.com
Please like VisualCron on facebook!
Offline Support  
#7 Posted : Thursday, September 4, 2014 12:10:22 PM(UTC)
Support

Rank: Official support

Joined: 2/23/2008(UTC)
Posts: 11,258

Thanks: 877 times
Was thanked: 450 time(s) in 427 post(s)
New build, changes:

[BUGFIX] Client->Loops->Fixed resizing error in window
[BUGFIX] Server->Email Task/Notification->Fixed error "User authentication failed: No SASL mechanisms supported by both the client and the server (error code is 0)"
Henrik
Support
http://www.visualcron.com
Please like VisualCron on facebook!
Offline Support  
#8 Posted : Saturday, September 6, 2014 11:43:10 AM(UTC)
Support

Rank: Official support

Joined: 2/23/2008(UTC)
Posts: 11,258

Thanks: 877 times
Was thanked: 450 time(s) in 427 post(s)
New build, changes:

[FEATURE] Client/Server: SSIS Task->Added support for MSSQL 2014 SSIS package execution
Henrik
Support
http://www.visualcron.com
Please like VisualCron on facebook!
Offline KJDavie  
#9 Posted : Sunday, September 7, 2014 11:39:09 PM(UTC)
KJDavie

Rank: No customer

Joined: 9/25/2012(UTC)
Posts: 106
Australia
Location: Brisbane,Qld

Thanks: 17 times
Was thanked: 41 time(s) in 27 post(s)
Hi Henrik,

Thanks for that, and appreciate your efforts on keeping the Protocol changes down.

Its *really* helpful if the Protocol changes that you let us know, preferably in the Beta Log of changes as you have done in the past, and in the Protocol Number.

The ones that matter here are not extensions for new tasks, but changes to existing tasks of course . . .

i.e. 7.0.0 Beta

"[NOTE] Client/Server: Protocol has been updated - server and client needs to be on same version 7.0.0"

If the protocol changes then the impact analysis, testing , and the deployment change. . . .

We were intending to deploy 7.2.0 but pulled out when we hit issues with the new clients talking to the existing Protocol 7.0.0 servers . . . . . with unchanged Jobs and Tasks.

Now we *know* we will look to deploy 7.2.1 client and server once released as sets and manage the transition.

So we had no issues with 7.0.0 - 7.1.9 with <our Jobs> . . . . so 7.2.0 and 7.2.1 are using a revised <7.2.0 ?> Protocol

As a side issue, a solution to having a single PC easily talk to multiple server versions (either a fancier client that supports multiple protocols, or clear instructions & support for running multiple clients on the same PC during transition) is still something that would be helpful when this happens.

http://www.visualcron.co...sts&t=3297#post15769
KJDavie attached the following image(s):
20140908 Version 7.1.9.png
20140908 Version 7.2.1.png
Offline Support  
#10 Posted : Thursday, September 11, 2014 10:58:32 AM(UTC)
Support

Rank: Official support

Joined: 2/23/2008(UTC)
Posts: 11,258

Thanks: 877 times
Was thanked: 450 time(s) in 427 post(s)
New build, changes:

[BUGFIX] Client: Desktop Macro Task->Fixed a problem which could occur when saving the macro
Henrik
Support
http://www.visualcron.com
Please like VisualCron on facebook!
Offline Support  
#11 Posted : Tuesday, September 16, 2014 4:28:22 PM(UTC)
Support

Rank: Official support

Joined: 2/23/2008(UTC)
Posts: 11,258

Thanks: 877 times
Was thanked: 450 time(s) in 427 post(s)
New build, changes:


[FEATURE] Client/Server: Added Task->Amazon EC2 - Create snapshot
[FEATURE] Client/Server: Added Task->Amazon EC2 - List snap shots
[FEATURE] Client/Server: Added Task->Amazon EC2 - List addresses
[FEATURE] Client/Server: Added Task->Amazon EC2 - List key pairs
[FEATURE] Client/Server: Added Task->Amazon EC2 - List security groups
[FEATURE] Client/Server: Added Task->Amazon EC2 - List volumes
[FEATURE] Client/Server: Added Task->Amazon EC2 - Reboot instance
[FEATURE] Client/Server: Added Task->Amazon EC2 - Start instance
[FEATURE] Client/Server: Added Task->Amazon EC2 - Stop instance
[FEATURE] Client/Server: Added Task->Amazon EC2 - Terminate instance
[FEATURE] Client/Server: Added Task->Amazon EC2 - List instances
[BUGFIX] Server: Fixed a small database cleanup issue
[BUGFIX] Server: FTP Task->Fixed Copy/Move files sub folders issue
Henrik
Support
http://www.visualcron.com
Please like VisualCron on facebook!
thanks 1 user thanked Support for this useful post.
Beylie on 9/17/2014(UTC)
Offline Support  
#12 Posted : Wednesday, September 17, 2014 3:18:32 PM(UTC)
Support

Rank: Official support

Joined: 2/23/2008(UTC)
Posts: 11,258

Thanks: 877 times
Was thanked: 450 time(s) in 427 post(s)
New build, changes:

[FEATURE] Client/Server: Added Task->Amazon EC2 - Delete snapshot
Henrik
Support
http://www.visualcron.com
Please like VisualCron on facebook!
Offline Support  
#13 Posted : Thursday, September 18, 2014 1:00:30 PM(UTC)
Support

Rank: Official support

Joined: 2/23/2008(UTC)
Posts: 11,258

Thanks: 877 times
Was thanked: 450 time(s) in 427 post(s)
7.2.1 was released officially today. Thank you for your testing.
Henrik
Support
http://www.visualcron.com
Please like VisualCron on facebook!
Offline thomas  
#14 Posted : Tuesday, September 23, 2014 1:15:12 PM(UTC)
thomas

Rank: Paid support

Joined: 12/10/2013(UTC)
Posts: 471
Norway

Thanks: 22 times
Was thanked: 181 time(s) in 137 post(s)
Hi

The new version caused a failure in one of our ftp download jobs. The job downloads a zip file over port 21. After we upgraded to 7.2.1 the taks fails with the following error:



Exception in Task: Unaccepted server reply (error code is 426)
Error (5) downloading file(s): stamdata.zip, err: Unaccepted server reply (error code is 426) (426 Connection closed; transfer aborted. Transferred 835,584 bytes in 83 seconds. 9KB/second.
), error code: 426
Exception in Task: No file(s) downloaded


There is a file there, and the connection works. I tried downloading using FileZilla and it went fine. After rolling back to 7.2.0, everything worked as it should.


Thomas
Offline Support  
#15 Posted : Tuesday, September 23, 2014 2:04:42 PM(UTC)
Support

Rank: Official support

Joined: 2/23/2008(UTC)
Posts: 11,258

Thanks: 877 times
Was thanked: 450 time(s) in 427 post(s)
Originally Posted by: thomas Go to Quoted Post
Hi

The new version caused a failure in one of our ftp download jobs. The job downloads a zip file over port 21. After we upgraded to 7.2.1 the taks fails with the following error:



Exception in Task: Unaccepted server reply (error code is 426)
Error (5) downloading file(s): stamdata.zip, err: Unaccepted server reply (error code is 426) (426 Connection closed; transfer aborted. Transferred 835,584 bytes in 83 seconds. 9KB/second.
), error code: 426
Exception in Task: No file(s) downloaded


There is a file there, and the connection works. I tried downloading using FileZilla and it went fine. After rolling back to 7.2.0, everything worked as it should.


Thomas


We have contacted you through email. Please setup up 7.2.1 on other computer and we will help testing why this happens.
Henrik
Support
http://www.visualcron.com
Please like VisualCron on facebook!
Users browsing this topic
Guest
Similar Topics
Force connection sftp 7.2.1 (General problem solving)
by ibmguy 5/15/2018 2:27:25 PM(UTC)
32 bit ODBC Oracle drivers and VisualCron 7.2.1 on a 64bit Windows7 (General problem solving)
by bertolm 8/11/2016 5:30:43 PM(UTC)
Upgrade Path - 7.2.1 to 8.0 (Installation / Upgrade)
by bbusse 12/22/2015 4:30:06 PM(UTC)
Issues after Upgrade from 7.2.1 to 7.6.5 (General problem solving)
by Kevin Restiaens 5/19/2015 10:44:38 AM(UTC)
VisualCron 7.2.1 SharePoint connection issue (General problem solving)
by bertolm 12/5/2014 3:45:06 PM(UTC)
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Scroll to Top