Issue with VB6 Application Running Crystal Report only when Task run from... - VisualCron - Forum

Community forum

gjenkins
2020-02-10T17:19:26Z
We have a very niche issue where we want to run a VB6 executable that generates several crystal reports. It works if we run the executable manually, however if we run the executable as a task from VisualCron we get the error "Automation error The object invoked has disconnected from its clients. -2147417848". We were able to trace the point of failure to the line of code "Form1.CrystalReport1.Action = 1", which just executes the actual report once all the parameters have been set. Any suggestions how to fix?
Support
2020-02-11T14:16:06Z
Originally Posted by: gjenkins 

We have a very niche issue where we want to run a VB6 executable that generates several crystal reports. It works if we run the executable manually, however if we run the executable as a task from VisualCron we get the error "Automation error The object invoked has disconnected from its clients. -2147417848". We were able to trace the point of failure to the line of code "Form1.CrystalReport1.Action = 1", which just executes the actual report once all the parameters have been set. Any suggestions how to fix?



Hi, it sounds like some permission issue. Could you try running it in Foreground instead of background? Also, screenshots of your current task settings would be helpful, you could mail those to support@visualcron.com
Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
gjenkins
2020-02-12T19:25:01Z
We actually got around this by updating to a slightly newer version of VisualCron. Thank you for the reply!
Support
2020-02-13T10:34:17Z
Originally Posted by: gjenkins 

We actually got around this by updating to a slightly newer version of VisualCron. Thank you for the reply!



That's good! Thanks for updating.
Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
Scroll to Top