Please note that VisualCron support is not actively monitoring this community forum. Please use our contact page for contacting the VisualCron support directly.

As of last night our Office 365 smtp relay no longer works with VisualCron. We can use it from other systems on the same server, with the same credentials etc. But for some reason it absolutely refuses to work with VisualCron.

There is a [Solved] thread in the past that details the settings that are required to make Office 365 smtp work, and we used that post in the past to setup our initial Connection, but it no longer works. We have rebooted the server, upgraded VisualCron to the latest version, deleted and rebuilt the Connection from scratch. We've tried to use an IP address instead of Nothing seems to work. Here are the settings we are currently using:

Port: 587
Crypto Protocol: SSL
Security Mode: Explicit

We have tried every combination of SSL/TLS and Explicit/Implicit. The only change that occurs is the error number we receive. The error when trying to use the above configuration is:

"Connection test failed. Error: Unhandled error: Connection Lost (error code is 10058)"

Any help would be appreciated. Anyone out there have a successful connection to Office 365? If so, what are your settings?

Thanks in advance for any feedback.
Forum information
This is related to which versions of SSL Office 365 support. The component that we use changed the default versions that is allowed for communication to prevent using old SSL which Office 365 probably still use. But we have created a new version where you can select which versions to support (by default all allowed). You can download this version here: 
Please like  VisualCron on facebook!
Thank you so much for the information. Any idea when this version will be officially released?
Just as an FYI, I downloaded this version and the Office 365 SMTP works perfect.
This solved our problem as well. Thank you.
Scroll to Top