task status running, but process has stopped - VisualCron - Forum

Community forum

j.mason@epyx.co.uk
2019-04-25T15:32:49Z
Hi
we are experiencing a problem in visualcron 8.5.0 where the task status remains as running after the process has ended. This means that the triggers to start those jobs are ignored since VC thinks the task is still running.

This is on a virtual server running windows server 2008 R2 standard server, swervice pack 1, 64bit. Xeon cpu v3 @2.50Ghz, 2 processors, (8 logical).

If we try to stop the task there is an error and the vc status remains as running:
4/24/2019 7:47:44 AM Info User 'Mark Hughes' - Updated Task: FTP process
4/24/2019 7:47:47 AM Info User 'Mark Hughes' - Tries to kill/stop all processes from specified Task (FTP process)
4/24/2019 7:47:47 AM Err KillProcessAndChildren->Unhandled exception: System.ArgumentException: Process with an Id of 3900 is not running.
at System.Diagnostics.Process.GetProcessById(Int32 processId)
at VisualCronService.ProcessAPI.KBPOKGFBMDBMPJHNOIEKMKFBABNECAIFGADA(I

I saw another post in this forum that was similar, however no resolution.
Hope you can help
regards
John
j.mason@epyx.co.uk
2019-04-29T10:04:41Z
Support
2019-04-29T11:02:53Z
Which exact Task type is it?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
j.mason@epyx.co.uk
2019-04-29T11:33:32Z
Hello Henrik, thanks for responding.
These are execute tasks, running our bespoke console applications.
We have them set up so that they receive a start trigger every 10 minutes, with 'do not start if the job is already running' selected.
The console applications run for a long time, usually 23.6 hours, then they shut themselves down between 8:55pm and 9:15pm.
Task credential is a service account that is in the local admin group for that server.
Maybe this is a windows compatibility thing?

regards John
Support
2019-04-30T08:09:48Z
Are you a part of Epyx limited? Just so we can connect your user with the right company.


Do you feel the problem could be in those cases when it is running longer than 24 hours?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
j.mason@epyx.co.uk
2019-04-30T10:54:43Z
Hi Henrik
Yes, sorry I didn't explain, yes I am a developer at epyx limited. Is it more appropriate to raise a service call?
The problem processes are running for less than 24 hours. Visualcron thinks the processes are still running after they have stopped.
  log_server20190425.txt (417kb) downloaded 26 time(s).

I have attached some log files that may help diagnose it.
regards
John Mason
Support
2019-04-30T14:51:26Z
No, it is just that we want to associate your account with the company so we can know the support level.

Please send the following info to support@visualcron.com:

1. the files (zipped)
2. the approximate time you think the process runs
3. screenshots of Execute settings
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
j.mason@epyx.co.uk
2019-05-01T09:18:26Z
Good morning Henrik,
My colleague Michal Sramek will be forwarding the info.
Thank you for your support.
regards
John
j.mason@epyx.co.uk
2019-05-10T10:50:10Z
RESOLVED.
VC support team advised there is a bug in version 8.5.0, workaround is to install version 8.4.1
Support
2019-05-10T11:40:07Z
Originally Posted by: j.mason@epyx.co.uk 

RESOLVED.
VC support team advised there is a bug in version 8.5.0, workaround is to install version 8.4.1



Unfortunately we cannot reproduce this. So for understanding/fixing this we need your help as we do not have any other customer at the moment with this issue. The problem with resolving this for you was that, at the moment we were looking at your files you had set it to start every second which flooded the logs so it was extremely hard to follow.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Scroll to Top