FTP/FTPS/SFTP/SCP Task Download Issues - VisualCron - Forum

Community forum

stevja01
2019-05-22T18:14:01Z
VisualCron: 8.4.1
We are randomly having issues with task type below on a WEEKLY basis:
Task Type: FTP/FTPS/SFTP/SCP

1. Files do not download from client's FTP site at all, No Credentials and/or Credentials used
2. Files download successfully, No Credentials and/or Credentials used

Environment:
We use VisualCron Default Admin logon to always start up VisualCron on our production Windows server.
Windows Server 2007, SP 2; 64-bit OS

Do you have any idea why we might have these failures? Is there something with this server version that might be causing it, though it just started.
If there are any logs I can share, let me know WHERE and HOW and I can send.
Support
2019-05-27T12:49:41Z
It depends on what kind of error you get?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
stevja01
2019-05-28T17:15:50Z
Here are the 2 errors we had last week downloading from our client's FTP. Error 2 happened repeatedly, i.e. 10+ times:

Error 1:
Exception in Task: SevenZip.SevenZipArchiveException: Invalid archive: open/read error! Is it encrypted and a wrong password was provided?
If your archive is an exotic one, it is possible that SevenZipSharp has no signature for its format and thus decided it is TAR by mistake.
at VisualCronService.ProcessTaskArchiveDecompressClass.CDJMFGBLNJDPDEJFDKHPAHBBBBMJAIAOLEGJ() in C:\sourcefiles\code\VisualCronService\Jobs\TaskProcesses\File\Archive\clsProcessTaskArchiveDecompress.vb:line 254 - file: E:\FILE_NAME.zip

Error 2:
Exception in Task: Unaccepted server reply code 425
Error (5) downloading file(s): FILE_NAME.txt, err: Unaccepted server reply code 425 (425 Can't open data connection.), error code: 115713
Support
2019-05-29T14:11:32Z
Error 2 might be something with PASV data channel limitations. Normally server has x number of Connections it can have open at the same time against the server. Maybe you hit the limitation. In this case VC is just returning the error.

About Error 1. Most likely something wrong with the file. I suggest putting that file aside and test if you can reproduce it in VisualCron. If you can, please send it to support@visualcron.com
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
stevja01
2019-05-30T22:02:55Z
Thanks for the info.
I'll follow up with our data provider re the #connections to the FTP site and if they have any logs that might explain why we are having connectivity issues. We had them again this week, but just changed the Credentials to another logon and it worked. We seem to change those randomly and the 2nd try will work. So very odd issue.
Support
2019-05-31T08:01:04Z
Originally Posted by: stevja01 

Thanks for the info.
I'll follow up with our data provider re the #connections to the FTP site and if they have any logs that might explain why we are having connectivity issues. We had them again this week, but just changed the Credentials to another logon and it worked. We seem to change those randomly and the 2nd try will work. So very odd issue.



Make sure just that the VisualCron service run as LocalSystem and only use Credentials when needed. This will help in these scenarios.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
stevja01
2019-05-31T22:16:47Z
We are downloading several files right in a row, multiple tasks in same job.
Is it possible that our repeated connection to the FTP site may be causing issue?
After we connect to FTP and download the file, does it log us off?

Support
2019-06-04T08:52:57Z
Originally Posted by: stevja01 

We are downloading several files right in a row, multiple tasks in same job.
Is it possible that our repeated connection to the FTP site may be causing issue?
After we connect to FTP and download the file, does it log us off?



We do disconnect after each Task.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
stevja01
2019-06-10T13:49:05Z
Support we upgraded to VisualCron 8.4.1 in February which is when these FTP issues started happening.
Is there any bug reported w/this version related to FTP?

Last week, we had 1 task fail trying to get a connection after the PASV step, but then team tried again and it worked.
So far, when we do have a failure, they always occur at the same step, after PASV, trying to get a connection.

We did check with our client re their FTP site and they haven't made any changes on their side. Their response is below.

"Client would like to know if you moved over to any new FTP software, implemented new routers or made changes to firewalls/settings. Client has not made any changes to their FTP software or site in 2019"
Support
2019-06-10T19:49:05Z
Originally Posted by: stevja01 

Support we upgraded to VisualCron 8.4.1 in February which is when these FTP issues started happening.
Is there any bug reported w/this version related to FTP?

Last week, we had 1 task fail trying to get a connection after the PASV step, but then team tried again and it worked.
So far, when we do have a failure, they always occur at the same step, after PASV, trying to get a connection.

We did check with our client re their FTP site and they haven't made any changes on their side. Their response is below.

"Client would like to know if you moved over to any new FTP software, implemented new routers or made changes to firewalls/settings. Client has not made any changes to their FTP software or site in 2019"



Not that we know of. But can we reproduce it from here any way?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
stevja01
2019-06-10T21:25:52Z
I'm not sure how to reproduce it. It's randomly happening and it's not always the same download task, even though we are downloading all 40+ files from the same site. We do use VARIABLES in the file names and this is the other odd thing. I can clearly see the file on FTP, but if I do a QC check to see if it finds a file using VisualCron, it sometimes will pull back a file match and other times no. So that's odd too!
Support
2019-06-19T19:44:24Z
Originally Posted by: stevja01 

I'm not sure how to reproduce it. It's randomly happening and it's not always the same download task, even though we are downloading all 40+ files from the same site. We do use VARIABLES in the file names and this is the other odd thing. I can clearly see the file on FTP, but if I do a QC check to see if it finds a file using VisualCron, it sometimes will pull back a file match and other times no. So that's odd too!



Best way would be to enable logging of sent and received data in the Connection. Then you will see the communication and exactly what you get from the server.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Gavin Langston
2020-04-27T23:12:34Z
Is there a way to set the limit for VC on the number of connections to an FTP server to avoid the error listed above (115713)? The service that we connect to has a limit of 8 connections per ID and we appear to hit this limit every time a VC job connects to it.
hjohnson
2020-05-22T16:56:30Z
I am having the same issue as Gavin, except that for each 1 disconnect VC is logging in 3 times. The company has a limit of 5. Why would VC not be disconnecting after each login? I have enabled extra task debugging and have gotten nothing. This happens on a random basis. This is for an SFTP(SSH - Secure Shell) connection.
Support
2020-05-27T13:23:13Z
Originally Posted by: hjohnson 

I am having the same issue as Gavin, except that for each 1 disconnect VC is logging in 3 times. The company has a limit of 5. Why would VC not be disconnecting after each login? I have enabled extra task debugging and have gotten nothing. This happens on a random basis. This is for an SFTP(SSH - Secure Shell) connection.



Hi,

Currently we have this option available only for FTP connections, not SFTP. We are working on implementing it for SFTP as well though, but we can not give you an exact date on when it will be available. I've noted this thread so i'll reply here/quote you here when we have more information about it or when its' ready for testing.
Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
hjohnson
2020-06-02T19:41:17Z
Originally Posted by: Support 

Originally Posted by: hjohnson 

I am having the same issue as Gavin, except that for each 1 disconnect VC is logging in 3 times. The company has a limit of 5. Why would VC not be disconnecting after each login? I have enabled extra task debugging and have gotten nothing. This happens on a random basis. This is for an SFTP(SSH - Secure Shell) connection.



Hi,

Currently we have this option available only for FTP connections, not SFTP. We are working on implementing it for SFTP as well though, but we can not give you an exact date on when it will be available. I've noted this thread so i'll reply here/quote you here when we have more information about it or when its' ready for testing.




Will this fix the issue of for every 1 disconnect there are 3 connects, also? So, it looks to the vendor's server that we have logged in 3 times but only disconnected once.
Support
2020-06-03T09:29:34Z
Originally Posted by: hjohnson 

Originally Posted by: Support 

Originally Posted by: hjohnson 

I am having the same issue as Gavin, except that for each 1 disconnect VC is logging in 3 times. The company has a limit of 5. Why would VC not be disconnecting after each login? I have enabled extra task debugging and have gotten nothing. This happens on a random basis. This is for an SFTP(SSH - Secure Shell) connection.



Hi,

Currently we have this option available only for FTP connections, not SFTP. We are working on implementing it for SFTP as well though, but we can not give you an exact date on when it will be available. I've noted this thread so i'll reply here/quote you here when we have more information about it or when its' ready for testing.




Will this fix the issue of for every 1 disconnect there are 3 connects, also? So, it looks to the vendor's server that we have logged in 3 times but only disconnected once.



I can not make any guarantees on if it will fix it, hopefully it will. Once we've implemented it we can troubleshoot it further if it for some reason is not fixed with the implementation
Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
Scroll to Top