HTTP Response header - VisualCron - Forum

Community forum

Danny van Oijen
2020-04-30T07:05:22Z
Hi all,

Please take a look here: https://kb.vmware.com/s/article/56948 
It states when i successfully login i get a X-VMWARE-VCLOUD-ACCESS-TOKEN
However with the HTTP task of visualcron i don't see this header response, when i use Postman it works.

Is this a limitation of visualcron?
Support
2020-05-01T17:18:21Z
What do you mean you are not seeing it? In the Task we only return the main response - not headers. But maybe you want the headers alone as result?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Danny van Oijen
2020-05-04T06:07:08Z
Henrik,

Yes the problem is that the Authorization response of vCloud Director is in the Header.
Support
2020-05-06T10:20:29Z
I am not getting the full picture but we are not returning the headers as output but the general http response.

So, what you need is to be able to get headers, from a Task, as Variable?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Danny van Oijen
2020-05-06T10:26:57Z
Henrik,

When you see the link i have attached than you will get it i think.
Basically, the response of my POST is in the Header, not the Body...
But the Response Header is not shown in vcron.
Support
2020-05-07T15:37:55Z
I am not sure I see the problem.

It seems you want to call two links.

In the second HTTP request you want to use a specific HEADER. What is the problem with this?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Danny van Oijen
2020-05-08T09:35:20Z
Henrik,

No i do just 1 call.
But the response i get is not in the return header and it don't see that in vcron.
Nevermind, i solved it via powershell.
Support
2020-05-08T11:59:55Z
Just want to understand. You say you do not see the result in response header. We do not return any headers. We just return the httpwebrequest response. If you share your code we might be able to confirm this and implement this support in VisualCron.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Danny van Oijen
2020-05-08T12:07:08Z
Henrik,

That is exactly the issue.
The response is in the header area.
See: https://kb.vmware.com/s/article/56948  Point 8 "In 'Headers', copy the x-vcloud-authorization token."
Support
2020-05-12T15:34:27Z
Thanks for confirming. We will look at implementing this.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Danny van Oijen
2020-06-02T13:04:42Z
Henrik,

I saw you implemented it in version 9.2.5, nice!!! thanks!!!
Works like a charm.

Support
2020-06-16T11:32:28Z
Great - thanks for confirming!
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Scroll to Top