Community forum

Please note that VisualCron support is not actively monitoring this community forum. Please use our contact page for contacting the VisualCron support directly.

  •  jm
  • Paid support Topic Starter
Running v4.8.4, build 32133

I have a server (2003 STD SP2, IBM X3650)running basic jobs that requires a smart card for encryption/decrytion for some of the jobs.
All the Jobs simply run batch files from various locations, and I'm using a local admin account to run these jobs from VC.

Everything has been working great for ages, until the other day when we upgraded the smart card as instructed by our partner financial institution.
Since the upgrade when each job runs, the actual job runs and reports success (background) but it can't detect the security token so the job doesn't actually run.
I have confirmed the token is active, and I have tried restarting the visual cron service.
Has anyone else out there experienced a similar issue?
The token is now upgraded to 2048 bit encrption.
I have tried creating a new job but same issue.

Forum information
Just a thought:
It could be that during the installation of the new smartcard software some files are overwritten used/belonging to Visualcron.
You can try reinstalling the visualcron software to be sure Visualcron has the right files.

But, it looks like Visualcron works fine. It starts your jobs, it just can't see the smartcard reader.

On other thought:
The smartcard software is changed.. What about the commands in the batch file. Are they still the same? Could be that you have to use different commands for the higher encryption.

Final thought:
What if you start the batchfiles without Visualcron? When that fails also, it's not Visualcron related.

Uses Visualcron since 2006.
  •  jm
  • Paid support Topic Starter
Thanks for the post Erik,

When I run the jobs manually they work.
I noticed that the smart card config files point to certain dll's that aren't available in system32, and the old ones have also been removed.
The vendor has requested I roll back to the previous smart card for now, and I'll do some more testing with the new smart card and drivers.
If the same thing happens I'll try reinstalling VC as you have suggested.

jm wrote:

Thanks for the post Erik,

When I run the jobs manually they work.

I assume you mean that you run from commandline and not running Jobs manually from VisualCron?
Please like  VisualCron on facebook!
  •  jm
  • Paid support Topic Starter
sorry for the late response,
yes the jobs run manually from the cmd line work fine.

Our partner is sending out a new card reader and smart card, so will try again when these come out in a week or so.
If same thing happens I'll try reinstalling VC.

Scroll to Top