File Copy task - same file copied to multiple destinations goes missing - VisualCron - Forum

Community forum

buzzlightyear
2021-04-22T11:51:12Z
We have a job that triggers on a file create once it has been released. It has a single File Copy task, with two copy steps copying the same file to two different destinations. The 2nd step also has the 'Delete source file after copy' box ticked.

We have other jobs that do similar copies, and have noticed that files sometimes go missing. What happens is that the file is in the location for the 2nd copy, but not in the location for the 1st copy, which does not have the delete command. No error is generated, and the output shows that the files were copied.

Does VisualCron execute these file copies in parallel perhaps, which means that the 2nd copy sometimes deletes the file before the 1st copy has completed, and causes it to silently fail?

Would like to hear if other users have similar Copy tasks with multiple steps copying the same file, and have similar issues.
Support
2021-04-22T12:35:41Z
Originally Posted by: buzzlightyear 

We have a job that triggers on a file create once it has been released. It has a single File Copy task, with two copy steps copying the same file to two different destinations. The 2nd step also has the 'Delete source file after copy' box ticked.

We have other jobs that do similar copies, and have noticed that files sometimes go missing. What happens is that the file is in the location for the 2nd copy, but not in the location for the 1st copy, which does not have the delete command. No error is generated, and the output shows that the files were copied.

Does VisualCron execute these file copies in parallel perhaps, which means that the 2nd copy sometimes deletes the file before the 1st copy has completed, and causes it to silently fail?

Would like to hear if other users have similar Copy tasks with multiple steps copying the same file, and have similar issues.



That shouldn't be possible no, please send screenshots of your task setup (the relevant copy task) and the trigger settings to support@visualcron.com and refer to this post

Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
buzzlightyear
2021-04-22T13:50:03Z
Thank you, I've sent the email with screenshots of the trigger and Copy task steps.
Joey S
2021-04-22T21:38:46Z
I was thinking that maybe having a file with the same name in destination #1, that is locked (ie 'Open') would cause this but I tested in v9.6.5 and the task will simply fail if it cannot overwrite the file in copy #1.

With that said the what you could do for a test would be to separate your copy process into two tasks

Task #1 should be copy to destination #1
Task #2 should be copy to task #2.


That way you san see what is happening a little better AND it is pretty easy to clone the task and make this work to troubleshoot.
buzzlightyear
2021-04-23T07:03:48Z
Splitting it into two tasks will very likely take away the problem, but doesn't get us to a cause and resolution. The functionality should work with multiple steps, we just need to discover what goes wrong. We have quite a few tasks with this configuration, it's not desirable to go and split them all.
Support
2021-04-23T12:30:55Z
Dealing with this via email for now

Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
buzzlightyear
2021-05-14T07:17:41Z
Hi, could you please advise of progress on this issue?

Thanks!
Support
2021-05-14T12:01:45Z
Originally Posted by: buzzlightyear 

Hi, could you please advise of progress on this issue?

Thanks!



Hi,

Can you reply to our email thread via email?
Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
buzzlightyear
2021-05-17T08:41:57Z
Originally Posted by: Support 

Originally Posted by: buzzlightyear 

Hi, could you please advise of progress on this issue?

Thanks!



Hi,

Can you reply to our email thread via email?



I'd be more than happy to, however, I have not seen anything on email. Can you please advise when an email was sent, so I can trace it?
Support
2021-05-21T08:44:36Z
Originally Posted by: buzzlightyear 

Originally Posted by: Support 

Originally Posted by: buzzlightyear 

Hi, could you please advise of progress on this issue?

Thanks!



Hi,

Can you reply to our email thread via email?



I'd be more than happy to, however, I have not seen anything on email. Can you please advise when an email was sent, so I can trace it?



Hm, i thought there was as ongoing support case via email regading this, but i can not find any emailthread with your domain (the emaildomain connected to your forumaccount here)

Please send an email to support@visualcron.com with some info/link to this thread
Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
Scroll to Top