Bug: SFTP connection failure after upgrade from 9.9.6 to 9.9.7 - VisualCron - Forum

Community forum

SickPup404
2022-04-25T15:05:18Z
We have an existing job that uses an FTPS connection using public key authentication.

After upgrade from 9.9.6 to 9.9.7, the connection stopped working. I tried to delete and re-add the connection and the SSH keys, but the connection still failed. I rolled back to 9.9.6 and the connection works again. I then re-applied the upgrade to 9.9.7 and the connection fails again.

When using the "Test" connection, the following message is displayed:
Connection test failed.  Error: Connection lost due to error 96258


When a job runs using the connection, the following errors are shown in STDERR:
Authentication failed for type 'public key'
SFTP Error: 114
Connection lost due to error 96258


The connection works under 9.9.6 and WinSCP connections between the same hosts work.

My current workaround is to continue with 9.9.6.

Let me know if you need additional info or testing.

Thanks,
Steve
Michael Fjellström
2022-05-13T13:34:49Z
Originally Posted by: SickPup404 

We have an existing job that uses an FTPS connection using public key authentication.

After upgrade from 9.9.6 to 9.9.7, the connection stopped working. I tried to delete and re-add the connection and the SSH keys, but the connection still failed. I rolled back to 9.9.6 and the connection works again. I then re-applied the upgrade to 9.9.7 and the connection fails again.

When using the "Test" connection, the following message is displayed:

Connection test failed.  Error: Connection lost due to error 96258


When a job runs using the connection, the following errors are shown in STDERR:
Authentication failed for type 'public key'
SFTP Error: 114
Connection lost due to error 96258


The connection works under 9.9.6 and WinSCP connections between the same hosts work.

My current workaround is to continue with 9.9.6.

Let me know if you need additional info or testing.

Thanks,
Steve



Hi Steve,

We are working on this. I can confirm that this is an issue in 9.9.7 currently.
Scroll to Top