JSON Filter giving error after machine language change - VisualCron - Forum

Community forum

Cristian.refere
2022-04-29T14:59:41Z
Hello.

Yesterday as part of our normal configuration for our machines, i changed the local language for the machine from En-US to Pt-BR.

I had several tasks that were properly working as follows

Task A - HTTP GET which had as response an array JSON similar to this ["value1","value2",....]
Task B - JSON Filter. The filter i was using was a simple
  • , which turned the array into a column table, output MultiValue, Separator CrLf
    All of the tasks had the Variable {TASK(PrevTask|StdOut)}, so as to acquire the JSON from the previous task.
    So it turned the example into something like this

    value1
    value2
    value3

    After yesterdays changes, all of these tasks are giving the following error:

    Exception in Task: Unexpected character encountered while parsing value: U. Path '', line 1, position 1.

    As far as i know, nothing else but the machine languague has been changed.
  • Michael Fjellström
    2022-05-03T14:35:05Z
    Originally Posted by: Cristian.refere 

    Hello.

    Yesterday as part of our normal configuration for our machines, i changed the local language for the machine from En-US to Pt-BR.

    I had several tasks that were properly working as follows

    Task A - HTTP GET which had as response an array JSON similar to this ["value1","value2",....]
    Task B - JSON Filter. The filter i was using was a simple

  • , which turned the array into a column table, output MultiValue, Separator CrLf
    All of the tasks had the Variable {TASK(PrevTask|StdOut)}, so as to acquire the JSON from the previous task.
    So it turned the example into something like this

    value1
    value2
    value3

    After yesterdays changes, all of these tasks are giving the following error:

    Exception in Task: Unexpected character encountered while parsing value: U. Path '', line 1, position 1.

    As far as i know, nothing else but the machine languague has been changed.



  • Are you able to send us a job sample (without dependencies) to support@visualcron.com so we can try to reproduce this issue please?
    Scroll to Top