Delete file task failing - VisualCron - Forum

Community forum

mat@ida.dk
2010-05-28T15:42:18Z
Hej!

I am having trouble running a delete file task.

Background info:
VisualCron Client version 5.1.0
VisualCron server OS: Windows Server 2003 Standard with SP2

Task info:
Task type: Delete file

File filter info:
Location: \\<Server FQDN>\C$\Folder\Folder (Location folder i on another server in another domain. This server is running Windows server 2008 R2)
Date: If modified date older than 30 days ({DATENOWADD(Days|-30|dd-MM-yyyy)})

Delete settings:
Credentials: Job running with user credentials of a domain admin in the other domain where the folder is located.

Problem:
When running the task, it fails with the following info in the log:
Unhandled exception in Task: Access to the path '\\<Server FQDN>\C$\Folder\Folder' is denied.

What I have tried to solve the issue:
Running a cmd prompt from the Visualcron server with the runas command with the job credentials is working fine. I can delete files as expected.
I cannot see any blocked traffic in the firewall. I have even turned the firewall off. It is not a firewall issue.
I have run the utility Process Monitor on the Windows 2008 server. I don't see any activity when running the Delete file task.


Anyone have any ideas? Could it be a bug i VisualCron?


Thanks!

Matthew
Support
2010-05-28T15:53:35Z
Can you test not using the hidden folder (C$) but a "real" share name?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
mat@ida.dk
2011-03-25T13:50:49Z
Hello!

It's been awhile, but I've returned to this problem which I'm still having. Since I posted back in May of last year, we have upgraded to VisualCron version 5.6.0 build 32656.

I have tried to run the task with a "real" share name, but am getting the same result "Access to the path 'xxxx' is denied.

Any ideas? Thanks!

Matthew
Support
2011-03-25T13:51:55Z
You need to use Credentials to access network drives (UNC Paths). Create one and select it in the Task.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
mat@ida.dk
2011-03-29T10:52:59Z
Problem solved!

Turns out that there was a firewall issue after all (not on the client but on the network between the VisualCron server and client). I also found out that I was using the wrong credentials as there is a trusted domain setup from which I needed to use a user instead.

Thanks for your help!

Matthew
Scroll to Top