"Don't start Task if process is running" not working! - VisualCron - Forum

Community forum

vcdkk
  •  vcdkk
  • No customer Topic Starter
2010-07-08T15:59:34Z
I'm using a restart technique as described here http://www.visualcron.co...?g=posts&m=5532#5532  to ensure that all tasks in a job are running.

Sometimes VC accidentally starts one of the tasks twice even though that "Don't start Task if process is running" is checked.

I'm running VC 5.5.9

vcdkk
  •  vcdkk
  • No customer Topic Starter
2010-07-08T16:02:19Z
May I also say that the GUI glitch when pressing "Run Job" which also opens a new menu is very annoying!
Support
2010-07-12T13:16:52Z
I don't know if the glitch you are talking about is the sub menu, that is supposed to be there, to be able to choose if you want to run with or without Conditions.

vcdkk wrote:

May I also say that the GUI glitch when pressing "Run Job" which also opens a new menu is very annoying!



Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Support
2010-07-12T13:18:26Z
1. How long time is it between each start/trigger of Execute Task?
2. What kind of Trigger do you use?

vcdkk wrote:

I'm using a restart technique as described here http://www.visualcron.co...?g=posts&m=5532#5532  to ensure that all tasks in a job are running.

Sometimes VC accidentally starts one of the tasks twice even though that "Don't start Task if process is running" is checked.

I'm running VC 5.5.9



Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Support
2010-07-12T13:18:26Z
1. How long time is it between each start/trigger of Execute Task?
2. What kind of Trigger do you use?

vcdkk wrote:

I'm using a restart technique as described here http://www.visualcron.co...?g=posts&m=5532#5532  to ensure that all tasks in a job are running.

Sometimes VC accidentally starts one of the tasks twice even though that "Don't start Task if process is running" is checked.

I'm running VC 5.5.9



Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
vcdkk
  •  vcdkk
  • No customer Topic Starter
2010-07-13T10:14:36Z
It is a "Interval time trigger" running every 1 minute.

Support
2010-07-13T12:02:26Z
It is important to know, when debugging this, that "do not start if process is running" do only check for the process name you write. Are you sure that process itself isn't dead? We do not check if a Task or Job is running - just the normal Windows process.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
vcdkk
  •  vcdkk
  • No customer Topic Starter
2010-07-13T12:43:35Z
The process itself could indeed be dead. That is why we are triggering a restart every minute to ensure that all processes is running.



Job 1
task 1
task 2
task 3


Job 1 is re-running every minute to ensure that the tasks 1-3 are running.
Support
2010-07-13T13:24:30Z
So, that is the problem then?

Let say you have the Execute Task on Task 1 then it can still start the Job again if 2 and 3 is running.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
vcdkk
  •  vcdkk
  • No customer Topic Starter
2010-07-13T13:26:01Z
we do never execute the tasks directly, only the job.

Support
2010-07-13T13:27:52Z
Yes, but if you are running Tasks in order. And use the feature on Task 1. And it completes that Task 1 - then, the Job can indeed start again (even though Task 2 or Task 3 is running) because the checkbox you are talking about just checks for a specific system process.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
vcdkk
  •  vcdkk
  • No customer Topic Starter
2010-07-13T13:38:03Z
the Job has not checked "Run Tasks in order"

Job
task 1 (Don't start Task if process is running)
task 2 (Don't start Task if process is running)
task 3 (Don't start Task if process is running)

When i manually run the Job it seems to work fine. Task 1-3 are not running twice! But sometimes VC (when running the 1 minute trigger) starts one of the tasks a second time.

Support
2010-07-13T13:39:27Z
Have you checked "Do not start Job if it is already running" on Job?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
vcdkk
  •  vcdkk
  • No customer Topic Starter
2010-07-13T13:40:49Z
No, as described in http://www.visualcron.co...?g=posts&m=5532#5532 

[ ] Job "Do not run job if it's running"
[X] Task Don't start Task if process is running".
Support
2010-07-13T13:42:48Z
If you do not have that checked the Execute Task could start - if the process is dead (even though other Tasks are running). Also, the other Tasks will start every minute.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
vcdkk
  •  vcdkk
  • No customer Topic Starter
2010-07-13T13:52:04Z
The job MUST start. That will ensure that if one of the tasks has crashed, it will be restarted!

It should not restart a already running task (that is why I use "Don't start Task if process is running")

Also, it works! But not always.

When i manually starts the job (when all the tasks are running) it says "Process was already running - command was not executed" which is good. But sometimes it starts a task the second time, which is bad!

Could you please setup the same job and tasks to see what i mean!

Stig




Support
2010-07-13T15:16:59Z
We set up one Job with one Task. That Execute Task is starting Notepad. On the Task settings we set "Don't start if process is running" (notepad.exe).

On the Job we unchecked:

"Do not start if Job is already running"
"Run Tasks in order"

We set a time trigger every 9th second. We ran it for about 15 minutes and it did not start more than one process at a time. Please try the above with notepad.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
vcdkk
  •  vcdkk
  • No customer Topic Starter
2010-07-13T15:31:30Z
OK - you agree it should work.

I think it is important (to see the error) that there is more than 1 task in the job, and that occasionally some of the tasks are not running when the job is triggered.
Support
2010-07-13T15:36:36Z
We will continue our tests with several tasks.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
vcdkk
  •  vcdkk
  • No customer Topic Starter
2010-07-14T08:06:20Z
I found a way to see the error. Stop the Job. Double click "Run Job".

This is off course not the way the error appears in our production system, but it shows that a task can run twice, even though that “Don't start Task if process is running" is checked.
Support
2010-07-14T09:22:25Z
This event could happen and we cannot guarantee anything if you are looking for the process like this. The reason is because VisualCron is faster to Execute before any process is created in the system. We just do a check if the process exist before starting and it can take some milliseconds -> seconds before the process is fully created in the system.

vcdkk wrote:

I found a way to see the error. Stop the Job. Double click "Run Job".

This is off course not the way the error appears in our production system, but it shows that a task can run twice, even though that “Don't start Task if process is running" is checked.



Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
vcdkk
  •  vcdkk
  • No customer Topic Starter
2010-07-14T09:57:26Z
yes and that is why VC fails.

You need to lock around the task starting section and wait until the process is started. At least give me the possible to customize this.

If not the feature "Don't start Task if process is running" has no value. It is broken.

Regards
Support
2010-07-14T10:05:59Z
I would not say it is broken because it does what it is supposed to do. You need to decide if you want to check for a particular Task or process. Those two give very different results. If we added both a Task and process lock it would give a total different meaning. You can add both if you want adding a Condition to see check if the Task is running or not. But placing both functionalities on the process check button would give a different meaning.

But in your case you said that "double click" was not the problem. So the process check should not be the problem you experience.

vcdkk wrote:

yes and that is why VC fails.

You need to lock around the task starting section and wait until the process is started. At least give me the possible to customize this.

If not the feature "Don't start Task if process is running" has no value. It is broken.

Regards



Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
vcdkk
  •  vcdkk
  • No customer Topic Starter
2010-07-14T10:12:32Z
I'm not sure if understand you right, but it seems like I could do a "task check" in stead of a "process check", and that should work?

How do I do that?

Regards
Support
2010-07-14T11:20:43Z
Yes, create a Condition of type VisualCron that checks of that specific Task is running. Then select that Condition set on the Execute Task.

vcdkk wrote:

I'm not sure if understand you right, but it seems like I could do a "task check" in stead of a "process check", and that should work?

How do I do that?

Regards



Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Scroll to Top