API to read job status no longer woring in 5.6.2 - VisualCron - Forum

Community forum

jcarter7
2010-07-21T20:47:02Z
I upgraded my VC install yesterday to 5.6.2 (from 5.6.0), and now I am seeing that the previously working API calls to get Job status information is no longer working (no error, just no results. Tried to replace DLLs that my code is using with latest DLLs from new install, but that did not help. Any ideas?
Support
2010-07-21T22:35:26Z
Could you show some sample code?

Generally, no changes has been made at all regarding this. In fact, the VisualCron Client is using the same interface. Could you just test the beta 5.6.3 just to be sure?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
jcarter7
2010-07-22T15:16:05Z
s.Jobs.GetAll() is not returning any jobs. Same problem with 5.6.3 beta.
Support
2010-07-22T15:24:50Z
Is this a remote or local connection that you are trying to make?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
jcarter7
Support
2010-07-22T15:31:33Z
What if you turn off compression on the connection - does it still fail?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
jcarter7
2010-07-22T15:43:31Z
yes, it still returns 0 jobs with compression off. Here some more of my code:

Client c = new Client();
c.LogToFile = false;
Connection cn = new Connection();
cn.Address = "PROD";
cn.UserName = "USER";
cn.PassWord = "PASS";
cn.Port = 16444;
cn.UseCompression = false;
cn.ConnectionType = Connection.ConnectionT.Remote;
Server s = new Server();
s = c.Connect(cn, true);
List<JobClass> jobs = s.Jobs.GetAll();

Note that I am still using the VisualCron.dll and VisualCronAPI.dll from the version that I was on when I first wrote the code, which was 5.4.9 i think. The code continued to work fine after a couple upgrades, but stopped working after upgrading to 5.6.2. I tried overwriting the DLLs with the ones from 5.6.2 and 5.6.3, but it made no difference (I reverted the DLLs back to the older ones).
Support
2010-07-22T15:49:18Z
We did some changes in 5.6.2 so the server and client api is not backwards compatible. You should get a protocol error when connecting.

Make sure you are running 5.6.2 on both client and server side.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
jcarter7
2010-07-22T15:57:05Z
Not really sure what you are saying. As I said, I tried using the 5.6.2 DLLs with my API code connecting to a 5.6.2 server, and it did not work.
Support
2010-07-22T16:00:09Z
Ok, did not get that.

1. Do you get other values? Like Notifications and such?
2. is it possible to open up so we can test to connect to that server from our development machine?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
jcarter7
2010-07-22T16:01:09Z
If I recompile my code with new DLLs, it then works. But I could not just replace the DLLs. This means our whole app has to be redeployed. Would have been nice to know this in the release notes.
Support
2010-07-22T16:06:01Z
We will include that next time. It is very seldom we do that kind of change. Sorry for the inconvenience.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
jcarter7
2010-07-22T16:19:31Z
Can I downgrade my server back to 5.6.0 by just re-running the older setup?
Support
2010-07-22T16:22:05Z
Yes, you need to uninstall current version first.

Also, you may have to double check some settings:

1. if you used any PGP Tasks they have to be re-created
2. if you used a Credential on any File Filter should check if they are still selected.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
jcarter7
2010-07-22T16:25:36Z
I don't have the older setup, I saved the newer download on top of it. I can see v5.6.0 in the beta area, but is that link actully for a obsolete beta version, or is it the version that was officially released (non-beta)?
Support
jcarter7
2010-07-22T16:30:22Z
Similar Topics
Users browsing this topic
Scroll to Top