SFTP Component Not Connected - VisualCron - Forum

Community forum

PeterW
2010-11-02T15:13:51Z
Hello,

There is a particular SFTP site that I cannot seem to connect to. When I attempt to connect via the explorer window I get the folder list but then I immediately get disconnected (see attached image).

I turned on extended debugging and disabled all tasks in the job except the SFTP task that attempts to upload the files.


11/2/2010 8:44:50 AM	Info	User "Peter" - Ran Job: Kohls - NeuAnalytic Files
11/2/2010 8:44:50 AM	Info	Skipping Condition check because the Job was run manually.
11/2/2010 8:44:50 AM	Info	Task: Add comments to table and create note files was skipped because it was inactive.
11/2/2010 8:44:50 AM	Info	Task: DC2 Account was skipped because it was inactive.
11/2/2010 8:44:50 AM	Info	Task: DC2 Comment was skipped because it was inactive.
11/2/2010 8:44:50 AM	Info	Task: DC2 Transaction was skipped because it was inactive.
11/2/2010 8:44:50 AM	Info	Task: DCLG Account was skipped because it was inactive.
11/2/2010 8:44:50 AM	Info	Task: DCLG Comment was skipped because it was inactive.
11/2/2010 8:44:50 AM	Info	Task: DCLG Transaction was skipped because it was inactive.
11/2/2010 8:44:50 AM	Debug	Task (149817) was added to processlist: Send Files
11/2/2010 8:44:50 AM	Info	Task started: Send Files (149817)
11/2/2010 8:44:50 AM	Debug	FTP Command Count: 6
11/2/2010 8:44:53 AM	Err	Failed to get folder content from folder: dcm-kohls:/, err: SFTP component not connected
11/2/2010 8:44:53 AM	Debug	Commands done
11/2/2010 8:44:53 AM	Debug	Before dispose
11/2/2010 8:44:53 AM	Debug	Disposing timer
11/2/2010 8:44:53 AM	Debug	Trying to disconnect
11/2/2010 8:44:53 AM	Debug	Stopping watch
11/2/2010 8:44:53 AM	Debug	Before GetOutput
11/2/2010 8:44:53 AM	Debug	Before RaiseTaskCompleted
11/2/2010 8:44:53 AM	Info	Task completed: Send Files (149817)
11/2/2010 8:44:53 AM	Debug	Setting previous task in TaskProcessCompleted: Send Files (*** ID DELETED ***) in job: Kohls - NeuAnalytic Files
11/2/2010 8:44:53 AM	Debug	Process status - About to SendTaskProcess (149817)
11/2/2010 8:44:53 AM	Debug	Process status - About to RemoveTaskProcess (149817)
11/2/2010 8:44:53 AM	Debug	Task (149817) was removed from processlist: Send Files
11/2/2010 8:44:53 AM	Debug	Job (54049) was removed from processlist: Kohls - NeuAnalytic Files
11/2/2010 8:44:53 AM	Debug	Next execution (2) for job 'Kohls - NeuAnalytic Files' is: 11/3/2010 8:30:00 AM
11/2/2010 8:44:53 AM	Info	Job completed: Kohls - NeuAnalytic Files


Do you need any other information to investigate? We currently have a workaround to this problem. Filezilla can connect just fine so we are able to send the files manually.

Thank you,

Peter
File Attachment(s):
connection.bmp (1,001kb) downloaded 42 time(s).
PeterW
2010-11-02T15:17:20Z
I should also mention we are on version 5.6.2.
Support
2010-11-02T18:11:07Z
It looks like the target folder might be specified wrong. Please attach a screen shot of your settings.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
PeterW
2010-11-03T14:56:51Z
Here is a screenshot of the target folder. I've tried entering ".", "\", "/", and "./" in the destination folder text box. I am trying to upload 6 files into the root directory after the connection is made.

Thanks,

Peter
File Attachment(s):
folder.bmp (852kb) downloaded 63 time(s).
Support
2010-11-03T15:22:11Z
We could try to test connecting to the server if you send us a test account to support@visualcron.com

It seems like the server has a very different way of handling folders. What server name and version is it?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Scroll to Top