Upgrading to the latest version of VC - VisualCron - Forum

Community forum

Mark Johnson
2008-02-25T20:29:37Z
If I upgrade to the latest version of VC, will I need to re-import my jobs from a backup? Also, will my license key work for a current version or will I need to get a new one?

Thanks

Mark
Support
2008-02-25T20:46:39Z
We always recommend using the export function to backup your settings regulary and before any upgrade/install. But your settings will remain and your old license key will work.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Bankinvest
2008-02-26T09:25:59Z
Hi,

Always back-up your settings. Trust me :-)
Three times on three diferent Servers, I've been in the situation that VC apparently had deleted some Taskjobs. Why? I don't know...

Now We have a job exporting all settings everyday, by using this path:
\\[servername]\[folder]\VisualCron_Backup\{COMPUTER(Name)}\{DATEFORMAT(dd)}_VisualCronSettings.zip

By doing this you'll allways have 4 weeks of back-up.

Leif Østerlin
Bankinvest, Denmark

Leif Østerlin
IT Developer, BankInvest
Denmark
Support
2008-02-26T09:42:45Z
Unfortunately, this could happen before when the VisualCron service was aborted/killed while saving. Since all definitions are stored in one file it is extra sensitive. We have done some changes to prevent this.

If this should happen again with the 4.8.x or greater versions we would be greatful if you sent the log files along with the zipped settings in the settings folder to support@visualcron.com

It is especially strange if "just" some Jobs disappear - this should never happen. What we have added in a later version is the possibility to see who deleted a certain Job. This can be viewed in log_serverXXXXXX.txt.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Clicky73
2009-03-31T18:31:42Z
All,

Be careful when upgrading as we hit a big problem yesterday after upgrading from 4.9.40 to 5.0.7.

Most of our jobs are used to move files across the LAN\WAN as well as the rename and zip function.

After upgrade the Rename function does not have a destination folder. That means that it use to rename and move at the same time. Now it just renames.
The other thing was the copy completly failed on all tasks that used any kind of masking.

The Zip function worked but some of the settings have moved and had to go into them and re-tick these, eg include subfolders etc.

As this tool and file movement is continuous and critical we didnt have too much time to debug, so we had to roll back.

We will be look more closely into this at some later date and upgrade when we have some answers.

Anyone else come across this?

Support
2009-03-31T18:42:01Z
Hi,

thank you for your post. Do you think you can export your settings and send to support@visualcron.com and tell us which Jobs you had problems with. We have tried to modify existing Jobs/Tasks to match the new format but it seems we have failed in some ways.

We will check and go through the problem areas once we have received your file.

Thanks.



Clicky73 wrote:

All,

Be careful when upgrading as we hit a big problem yesterday after upgrading from 4.9.40 to 5.0.7.

Most of our jobs are used to move files across the LAN\WAN as well as the rename and zip function.

After upgrade the Rename function does not have a destination folder. That means that it use to rename and move at the same time. Now it just renames.
The other thing was the copy completly failed on all tasks that used any kind of masking.

The Zip function worked but some of the settings have moved and had to go into them and re-tick these, eg include subfolders etc.

As this tool and file movement is continuous and critical we didnt have too much time to debug, so we had to roll back.

We will be look more closely into this at some later date and upgrade when we have some answers.

Anyone else come across this?



Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Support
2009-04-01T17:10:40Z
Thank you for your files Mark.

We tried importing your Jobs into 5.0.9. and properties like Include subfolders where correctly moved. We believe the copy problem is the trailing slash which is removed at runtime in version 5.0.9.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
johannes.heesters
2009-04-24T16:45:56Z
Hi there,

we upgraded to 5.1 on some servers.

Since that we have the problem that zip files containing not only the file, also the directory structure with subfolders.
With the version before (4.7 ?) it worked.

We also have problems with jobs that move file with subfolder masking containing DATE variables. They will not be moved anymore since thsi update to 5.1

Any idea what we can do ?

Thanxs
Support
2009-04-24T16:50:19Z
1. Could you export a Job with a Compress Task that does not work properly?
2. Which date variable does not work?

johannes.heesters wrote:

Hi there,

we upgraded to 5.1 on some servers.

Since that we have the problem that zip files containing not only the file, also the directory structure with subfolders.
With the version before (4.7 ?) it worked.

We also have problems with jobs that move file with subfolder masking containing DATE variables. They will not be moved anymore since thsi update to 5.1

Any idea what we can do ?

Thanxs



Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
johannes.heesters
2009-04-24T17:03:31Z
Jobs exported and attached.
Task 2 and 4 are the problem tasks.

Variable: C_{DATEFORMAT(dd)}.zip

Support wrote:

1. Could you export a Job with a Compress Task that does not work properly?
2. Which date variable does not work?

johannes.heesters wrote:

Hi there,

we upgraded to 5.1 on some servers.

Since that we have the problem that zip files containing not only the file, also the directory structure with subfolders.
With the version before (4.7 ?) it worked.

We also have problems with jobs that move file with subfolder masking containing DATE variables. They will not be moved anymore since thsi update to 5.1

Any idea what we can do ?

Thanxs



File Attachment(s):
zip_rename_job.zip (4kb) downloaded 41 time(s).
Support
2009-04-24T17:22:49Z
I see no problem with: {DATEFORMAT(dd)} - what is the problem with this one?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
johannes.heesters
2009-04-27T09:29:21Z
I attach a PDF file that makes it easier to understand.
The jobs and tasks worked before version 5.1 without problems.
Since 5.1 the zip file contained a subfolder structure and the file is not renamed/moved anymore.

Support wrote:

I see no problem with: {DATEFORMAT(dd)} - what is the problem with this one?


Support
2009-04-28T17:05:33Z
I think you need to break it down. It is hard for us to validate your flow based on the content. If the rename task is the problem I would create a simple rename Task and try to run it. The actual Variable should work as expected. I am guessing it something else. The Rename Task has changed since 4.x version. The change is in the destination file and you may want to look at these settings.

The changes were made to support file masks in the source and destination filename.


johannes.heesters wrote:

I attach a PDF file that makes it easier to understand.
The jobs and tasks worked before version 5.1 without problems.
Since 5.1 the zip file contained a subfolder structure and the file is not renamed/moved anymore.

Support wrote:

I see no problem with: {DATEFORMAT(dd)} - what is the problem with this one?




Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
johannes.heesters
2009-04-29T08:25:17Z
Ok, we can stop the discussion as it is really hard to explain.
You wrote that you have attached a file, did i understand that correct ?
Because i can not find a file.

But what is about the ZIP file content ?
I wrote that since 5.1 the ZIP file contains the subfolder structure.
I do not want to have that, i want to have a flat ZIP file with the logfile in it.
You can see that in the screenshot in the wordfile.

I attach the screenshot of the ZIP file to this post.
The file is \\files\mirrorlogs$\files\D_28.ZIP.
Then you see that there are the subfolders \files\mirrorlogs$

Support wrote:

I think you need to break it down. It is hard for us to validate your flow based on the content. If the rename task is the problem I would create a simple rename Task and try to run it. The actual Variable should work as expected. I am guessing it something else. The Rename Task has changed since 4.x version. The change is in the destination file and you may want to look at these settings.

The changes were made to support file masks in the source and destination filename.


johannes.heesters attached the following image(s):
Support
2009-04-30T16:24:42Z
We will look at the archive Task and get back to you.

johannes.heesters wrote:

Ok, we can stop the discussion as it is really hard to explain.
You wrote that you have attached a file, did i understand that correct ?
Because i can not find a file.

But what is about the ZIP file content ?
I wrote that since 5.1 the ZIP file contains the subfolder structure.
I do not want to have that, i want to have a flat ZIP file with the logfile in it.
You can see that in the screenshot in the wordfile.

I attach the screenshot of the ZIP file to this post.
The file is \\files\mirrorlogs$\files\D_28.ZIP.
Then you see that there are the subfolders \files\mirrorlogs$

Support wrote:

I think you need to break it down. It is hard for us to validate your flow based on the content. If the rename task is the problem I would create a simple rename Task and try to run it. The actual Variable should work as expected. I am guessing it something else. The Rename Task has changed since 4.x version. The change is in the destination file and you may want to look at these settings.

The changes were made to support file masks in the source and destination filename.




Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Support
2009-05-03T20:18:13Z
Johannes, please try beta 5.1.2. which should fix the folder structure.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
johannes.heesters
2009-05-15T14:45:17Z
Thanxs, it works now.

Support wrote:

Johannes, please try beta 5.1.2. which should fix the folder structure.


Scroll to Top