VisualCron stopped running after drive space reached 0, even after cleanup - VisualCron - Forum

Community forum

Guest
  •  test
  • No customer Topic Starter
2011-05-04T16:00:51Z
Yesterday we ran into an issue where the physical drive that VisualCron was installed and running on ran completely out of space. Upon freeing up space from the server (2003) we noticed that VisualCron jobs were not running anymore. They work show as running after starting and never finishing. I will supply the cut of the log from the time frame of where we ran out of space, and the restart of the VisualCron server. The restart corrected the issue, but why did we have to restart in order to get it running.

Any thoughts?

thanks

Dennis Hepworth
Support
2011-05-04T16:12:50Z
We can see in the log that VisualCron restarted itself after the error. And we see some jobs kicking off after that. What exactly was not working (if you compare to the log)?

We know that a lot of strange things can happen - for examples, file triggers may not work if we are out of space.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Guest
  •  test
  • No customer Topic Starter
2011-05-04T16:23:24Z
From what I saw on the server itself was the jobs would start, but if there was a need to write something out, say a log, or information to a file, that task would not complete, it would just stay in running status. It was very strange.

thanks

Dennis Hepworth
hepworthd
2012-10-09T23:41:48Z
We once again ran out of disk space on our server, this shouldn't have happened, but it did. And once again, VisualCron (6.1.0) stopped responded, and required a server reboot to get it back online. This caused us major production issue's, can this please be investigated as to why this happens? I was not even able to stop the service, it basically consumed 100% cpu until the reboot.

thanks

Dennis Hepworth
Support
2012-10-10T06:20:19Z
We will try to reproduce this to see what the correct action should be for this. Thanks for the report.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
hepworthd
2012-10-10T17:14:08Z
One thing to note, VisualCron was installed on the C:, and we ran out of disk space on 😨.
Support
2012-10-11T06:42:42Z
Originally Posted by: hepworthd 

One thing to note, VisualCron was installed on the C:, and we ran out of disk space on 😨.



Ok, thanks for info.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
hepworthd
2012-10-29T12:15:35Z
Has there been any movement on this thread?

thanks

Dennis Hepworth
Support
2012-10-31T08:36:24Z
No, not yet. Creating this kind of environment is complex (as we both need debug and empty disk). As is very unusual and workaround (restart of service) is pretty straight forward together with the problem of reproducing we have not prioritized this issue very high.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
bbusse
2012-11-01T15:09:09Z
Dennis,

Is your 2003 server 32bit, and are you running the Final Build of VC 6.1.4 ?

I have the means to test and try to reproduce this, I just need to know more about your environment.


Since VC is installed to drive C, and it was drive D that filled up, I have some concerns about other settings on the server.

Is your system's pagefile on drive D?
Any other Environment Variables set to drive D? %TEMP%, %TMP%, etc.. ?
Basically, other than storage for files of some sort, what is drive D used for. Does VC use drive D in any way via Triggers or copy jobs, etc... that rely on drive D being there?

Anything you can think of related to VC's interaction with drive D and/or requirements of the OS on drive D would be helpful.

Brian
Support
2012-11-01T15:11:40Z
Actually we run out of diskspace on a dev computer today. We forced to fill up those last empty kB on the computer while running the Server in debug mode. We did not experience and hanging. Just a lot of other errors like it can't save new settings or log.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
bbusse
2012-11-01T15:16:32Z
Originally Posted by: Support 

Actually we run out of diskspace on a dev computer today. We forced to fill up those last empty kB on the computer while running the Server in debug mode. We did not experience and hanging. Just a lot of other errors like it can't save new settings or log.



Thats why i'm wondering if Dennis isn't running into a unique issue where pagefile, etc.. might be configured for drive D and the whole system has a possibility of becoming slighly unstable until rebooted, not just VC.

I'll test a few different scenarios on my 32bit 2003 Standard R2 SP2 Virtual server and post back.

Brian
Scroll to Top