[5.7.4] "Job Stop" Action does not "wait for completion" - VisualCron - Forum

Community forum

vcdkk
  •  vcdkk
  • No customer Topic Starter
2011-05-19T14:13:28Z
I'm using a Job with 2 tasks
1. Job - Stop Job : X
2. Job - Start Job : X

I want my job to restart all tasks in X. X is a Job with 5 always running tasks.

In the VC Client it says "❌ Run synchronous (wait for completion)"

The problem is that "1. Job - Stop Job : X" is not waiting until the job has completed.

Therefor i get some strange results. Sometimes only half of the tasks is running.




Support
2011-05-19T14:53:24Z
Which version are you using now?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
vcdkk
  •  vcdkk
  • No customer Topic Starter
vcdkk
  •  vcdkk
  • No customer Topic Starter
2011-05-23T08:52:55Z
vcdkk
  •  vcdkk
  • No customer Topic Starter
2011-05-26T08:48:19Z
Support
2011-05-26T08:53:27Z
Hi,

sorry for the late reply. No, we do not wait as Stop *should* be initiated right away. How does this create a problem for you? That the process is not killed in time or?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
vcdkk
  •  vcdkk
  • No customer Topic Starter
2011-05-26T14:11:45Z
How does this create a problem for you? That the process is not killed in time or?

As I described in the first post, it gives unpredictable results. Maybe because the processes are not stopped in time.

---

I have now found out that it is a GUI bug. First create a "Start Job" Task. Make sure "❌ Run synchronous (wait for completion)" is checked. Now change the task to a "Stop Job" task. The flag is still checked! ;(


Support
2011-05-26T14:18:32Z
We will fix this. We have already fixed the Startup trigger you mentioned.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Support
2011-05-26T15:56:11Z
This is now fixed for next release.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Scroll to Top