Remote Excute cannot access mapped driver - VisualCron - Forum

Community forum

tracey
2011-08-17T03:53:37Z
we have a application called RF which get input files and generate output files, if we run RF manually, the input file or output file working directory can be set to relative path, map driver or absolute path, and the RF works fine without any error.

But when we run RF by VisualCron Remote Excute, if the input file directory and output file directory are relative path and the relative path is in local drive, the RF works fine. but if the input file folder or output file folder points to absolute path or mapped drive, the Visual Cron shows “Success” status, but RF does not generate any output files.

Please help.
Support
2011-08-17T05:58:16Z
There are two ways to do this:

1. you use a Credential and instead of mapped drives you use UNC paths like \\servername\folder (recommended option)

2. You map the same drives again using the mapping tool in VisualCron
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
tracey
2011-08-17T06:41:01Z
Originally Posted by: Support 

There are two ways to do this:

1. you use a Credential and instead of mapped drives you use UNC paths like \\servername\folder (recommended option)

2. You map the same drives again using the mapping tool in VisualCron



The mapped drive's setup is inside of the application RF, not in VisualCron Remote Excute. We use credential in Remote Excute setting, and the credential has access to mapped drive as well.

If we run RF manually with mapped drives, it is working fine without any issue. It is only happened when run it by Visual Cron.
Support
2011-08-17T07:14:47Z
I was not reading it to closely. I thought you were using normal execute.

We managed to write a file to a shared drive when using remote execute - but only if we used UNC path like \\servername\folder\file - you cannot use logical drives like z:\ because they are not shared in that context.

What you can do if you really want to use logical drives is to map the drive first. Run your file and then unmap it - like this:

net use k: \\ip\sharedfolder /USER:"computername\username" password

echo "hello web server" > k:\remoteexecute.txt

net use k: /delete


The above is code to a batch file. What you need to do is to save that file to the local drive of the computer you want to execute on (not on the network drive).

Then use the local path in Command property of Remote Execute Task.

For example, if you save the file in c:\ as test.bat you use the Command:

c:\test.bat
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Scroll to Top