SFTP Connection Lost (error code is 10058) - VisualCron - Forum

Community forum

kyletraynor
2012-02-23T18:21:02Z
Hi,
We are trying out visual cron to automate some daily processes.

We had files uploading via SFTP just fine for a few days and now we get an error
Quote:

Authentication type 4 failed
SFTP Error 114
Connection Lost (error code is 10058)


If I go to the server explorer and try to open up the connection it still has this problem.

BUT - if I close out visual cron completely and open it again, i can open the connection just fine.

Does anyone have any idea what is causing this and how I can prevent this from happening in the future? To use this software we need it to be very reliable each day.

Thanks.
Support
2012-02-23T18:33:04Z
You did not say if you use password or public key authentication.

It sounds very strange. I have not heard about this kind of behavior before. It sounds more like a server problem if it work sometimes and sometimes not as we try to connect the same way each time.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
kyletraynor
2012-02-23T18:38:03Z
We are just using a username/password to connect.

I found this post yesterday when researching the problem:
http://www.visualcron.co...m.aspx?g=posts&t=708 
who had the exact same symptoms, but he solved it by moving a public key which we are not using to connect so I'm not sure what is causing it for us.

I turned on extended debug logging yesterday(and it failed again last night) and wanted to look at the log myself, and found the sdf file. But when I try to open it, it needs a password and is encrypted. Is there anyway I can open the file to see the logs?

Thanks.
Support
2012-02-23T18:40:10Z
You have the Job and Task history window - this way you can see historic output.

114 is indeed an authentication failure related to public keys.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Support
2012-02-23T18:42:10Z
Authentication type 4 failed means that password authentication failed. You should probably check the SSH server logs.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Scroll to Top