execute task - Standard output - get full output is disabled - VisualCron - Forum

Community forum

stuhlpfarrer
2012-04-27T12:46:07Z
The output window content is limited to 2000 Chararcters.

We have some task with more output, but the button to show the full output seems to be disabled.
So we have no possibilty to see the full output of our jobs.

But we also have tasks, where the button is enabled and showing the full output works.
Support
2012-04-30T07:36:13Z
It depends when you look at the output. Right now we only store 2000 characters in the history of a Task. We will increase this soon. So, full output, the actual realtime value is only available for an hour. After that, only the historic 2000 characters are available.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
stuhlpfarrer
2012-05-03T10:23:11Z
just updated to new version 6.1.0, started a job manually and tried the full output button, but it was disabled just after the job finished.

I would suggest, that if you limit the output to 2000 Characters or higher, to display the first 1000 Characters and then some ... and then the last 1000 Characters of the output.

So we could see the starting info and also the ending info of the job.
That would be a nice feature.

Support
2012-05-03T10:31:51Z
We did the following test with 6.1.0.

1. we created a File read Task that read a 6kB file
2. we ran the Job
3. we double clicked at the output
4. button was enabled and we clicked on "Get full output"
5. rest of window was filled

The button is only enabled if output is larger than 2kB.

1. How large is your output? (write output to file using Variable)
2. Can you reproduce the above?

Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
stuhlpfarrer
2012-05-03T11:33:17Z
Just found out the following:
the problem has nothing to do with the size of the output, but it depends on the content of the output.

I used this code in a batch file "test.cmd" and execute it with VC:
@echo off
for /L %%N IN (1, 1, 1000) DO echo This is the Number %%N bla äöü 


The problem only arises if the output has some german "umlaute" in it.
Without these, it works as expected, but with these, the full output is disabled.
Support
2012-05-03T12:27:13Z
Thank you for the report. Please test this version:

http://www.visualcron.co....aspx?g=posts&t=2434 
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
stuhlpfarrer
2012-05-10T08:29:23Z
Thank you for the update - now it works.
BTW: your support is immpressing!
Support
2012-05-10T17:15:21Z
Thanks for the update and feedback!
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Scroll to Top