Files are not being deleted - VisualCron - Forum

Community forum

Ian Buttaci
2013-08-16T10:09:12Z
I receive daily sales files which are put into a location on my network

I have a job that includes 2 separate tasks:

1. aggregates daily sales files
2. deletes the original daily files

For some reason the job does not delete the daily files.

However, when the task is run on its own it does delete them.

Does anyone know what might be causing the job not to run task 2?
Ian Buttaci attached the following image(s):
Support
2013-08-16T13:05:45Z
I can think of a couple of reasons:

1. Task 1 fails resulting in Task 2 not being run
2. Task 2 fails for some reason
3. Task 2 use the wrong file filter or a Variable that is not the same during normal runtime

What kind of Trigger do you use?
Please attach screenshots of settings.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Ian Buttaci
2013-08-16T13:34:39Z
Task 1 is running fine and doing what I want.

Task 2 doesn't even run when the job is run. But it does run when run on its own. So i guess there is something to do with the job settings?
Support
2013-08-16T13:54:10Z
Yes, Job or Task settings. Perhaps Conditions. You did not answer our other questions:

What kind of Trigger do you use?
Please attach screenshots of settings.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Ian Buttaci
2013-08-16T13:58:16Z
I have attached some screenshots to the first post.

I'm not using a trigger, just trying to run the job from the main processes screen by right clicking and 'Run Job'.
Support
2013-08-16T14:29:44Z
You should use the UNC path instead of logical drive path (Z:). Please try to change that and see if it helps.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Scroll to Top