New User, problem setting up first job - VisualCron - Forum

Community forum

calvin-c
2008-11-21T18:31:16Z
We just bought VC to replace Windows Task Scheduler & I'm trying to set up the first job (as a test). It should be simple as all I want to do is run a batch file at a specific time each day. I'm getting a variety of errors depending on what I try to do to get it to run.

Running on WinXP Pro, SP2. connected to a Netware 6.5 server (NW Client 4.91 SP1). I'd prefer to run the file from the network but when I run it using the UNC path for the Execute command I get the error "Unhandled error when trying to start process: The parameter is incorrect"

When I try running it from a local drive I get 'Incorrect function' when run using API code (stderr says 'The system cannot find the path specified'). When I run it using managed code I get "Unhandled error occurred when trying to start job. Error: The handle is invalid"

I'm wondering if the problem is the credentials. The Netware client automatically logs us into Windows with the Netware credentials, but perhaps VC needs to handle things differently? Or perhaps I need to specify the credentials differently for VC? Or am I just doing something totally screwed up? As I said, this is the first time we've tried to use VC & your tutorials don't seem to show how to set up even the simplest jobs so I'm really not sure what I'm doing from step one.
PeterW
2008-11-21T22:09:13Z
Hello,

When we first purchased VisualCron we set up a domain login specifically to run jobs on the network. It is possible the user you have set up in VisualCron does not have the proper permissions to run it. Does the user have access rights to the network share? Does it have access to the local machine where VisualCron is installed? One thing we ran into when we first set the software up is the password was not entered correctly for the user. Have you tried deleting the credentials that run this job and re-adding them? Are you able to login to the machine that has the batch job (using the credentials for the job) and if so, can the batch job be manually started?
calvin-c
2008-11-24T18:04:39Z
Apparently I wasn't clear. We've been using the same login on the same PC to run the same batch file. The only difference is that we'd like to run it from VisualCron rather than from Windows Task Scheduler. The only other change I made was after the initial problem-then I moved the batch file to the C: drive so I could be certain there wasn't any problem with VisualCron finding it since it appears VisualCron doesn't use mapped drive letters. (Although the batch file uses mapped drive letters, this should not be a problem if VC is logging in the same way a user would. I suspect it isn't.)

I'm wondering if there's a way to tell VC to simply use the currently logged on user? Although this might not work for most users, it'd work fine for us as we run it on a physically secured PC.

The job runs fine under Windows Task Scheduler using the same login. The only problem is that we can't set up a job to run on the last day of every month. VC should do this-except it won't run the job at all. Frustrating.
PeterW
2008-11-24T18:53:26Z
calvin-c wrote:

I'm wondering if there's a way to tell VC to simply use the currently logged on user? Although this might not work for most users, it'd work fine for us as we run it on a physically secured PC.



I'm not aware of a way to tell the software to use the currently logged in user. Just to make sure I understand, when you are viewing your "Manage Credentials" popup screen you see the same user that is running the job with Windows Task Scheduler? For example if you have user "MyWindowsDomainName\VisualCron" running the job in task scheduler you should see an entry under the name column in the "Manage Credentials" window as "VisualCron@MyWindowsDomainName".

Regards,

Peter
calvin-c
2008-11-24T21:24:01Z
Correct. Different format (domain/user vs user@domain) but same info. And I've double-checked the password since there's no way to see that.

Things I have not checked are whether the task runs properly under Windows Task Scheduler if the user is not logged on. Since it's the same user it's possible (even likely) WTS is using the drives mapped by the interactive login which connects to Netware. If that's correct, then I suspect WTS would fail if the user were not logged on (I don't intend to try this as there are many production jobs running under WTS that I don't want to screw up).

I've gone thru so many permutations I'm no longer certain which changes produced which error messages. I have seen a couple of interesting ones in the log though: "impersonation failed in task" and "The network name cannot be found". These occurred while using the UNC path.
PeterW
2008-11-24T22:07:02Z
Hmm. I'm at a loss as to what you could try next. Unfortunately I'm not familiar with Netware so I don't know if that could be part of the problem you are experiencing. I'm not sure if it would be feasible to run a test without Netware and see what the results are. If you haven't done so already I would suggest you email your log file(s) to support@visualcron.com and point them to this thread for a description of the problems you are having.

With regards to the impersonation errors the developers are aware of the issue. Read this thread for more information: http://www.visualcron.co...t.aspx?g=posts&t=328 

Good luck!
Scroll to Top