VMWare - vCenter Server - How do I setup connection? - VisualCron - Forum

Community forum

Michael Tebbs
2014-06-20T15:24:45Z
I'm trying to setup a connection between VisualCron v7.1.7 and vCenter Server Appliance v5.1.0.1235232. I've tried setting the address to the ip, ip:443, dnsname, dnsname:443 https://ip:443/sdk, https://dnsname:443/sdk, but I keep getting the following message when I try to refresh the Server VMX path: "An error occured (sic) while refreshing server lists, error:"

I have tried with VIX-1.12.3-1 and VIX-1.13.0-1.

How do I setup my vCenter connection in VisualCron?
Support
2014-06-20T20:20:54Z
Try just using the ip with http and port.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Michael Tebbs
2014-06-20T20:27:14Z
I tried that, too. Log shows it's trying to use port 21

6/20/2014 3:24:59 PM Info User 'Carl Worley' - Added Connection (root@https://dnsname:443:21)
Support
2014-06-20T20:35:06Z
What kind of connection type are you setting up? If you use VMWare port 21 is not used. Perhaps the interface might default to that but port 21 is not used.

You should try ip only (not dns name) to test with
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Michael Tebbs
2014-06-20T20:41:23Z
Here's how I added the connection:

Server -> Connections -> Add -> VMWare

Main Settings:
Name: vCenter
Address: https://dnsname:443
Authentication:
Username: username
Password: password
Support
2014-06-20T20:45:43Z
Just use the dns name or ip in Address field. No https and no port.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Michael Tebbs
2014-06-20T20:46:46Z
I did that too, but it still doesn't work. Log still shows it's trying to use port 21
Support
2014-06-20T20:51:55Z
Originally Posted by: Carl Worley 

I did that too, but it still doesn't work. Log still shows it's trying to use port 21



This does not make sense. Could you include the log? And what if you change the port in the Connection (not altering address).
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Michael Tebbs
2014-06-20T20:55:03Z
It doesn't give me an option to change the port.

Log:
6/20/2014 3:53:45 PM Info User 'Carl Worley' - Added Connection (root@dnsname:21)
6/20/2014 3:53:45 PM Debug Saving Connections
Support
2014-06-20T21:04:01Z
Ok, you can ignore that message. It is not actually using port 21. I *think* it is using port 443 by default - but I know this is something that you cannot control if you have set it to use other port than default.

Perhaps you have not installed the VIX API?

https://my.vmware.com/we...puting/vmware_player/5_0 
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Michael Tebbs
2014-06-20T21:05:32Z
I have tried with VIX-1.12.3-1 and VIX-1.13.0-1.
Support
2014-06-20T21:10:49Z
Please add a screenshot with the whole window including the error popup.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Michael Tebbs
Support
2014-06-24T07:40:00Z
I am attaching a debug version and hopefully we can get more answers. Please follow these steps:

1. download the attached version
2. install it
3. turn on Extended debugging in Server settings
4. Try to refresh the servers
5. send the file log_serverDATE.txt to support@visualcron.com
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Michael Tebbs
2014-06-24T13:53:14Z
When I installed the new version, I wasn’t sure how the old, remote client would work on the new server version, so I tried it from the client on the server – it worked.

Then I tried the old client (7.1.7) remotely, and I got the same error. The error happened between “ProcessTaskVMWareShared->Before executing” and “ProcessTaskVMWareShared->VMTask.Result has success value: True”

Then I upgraded the remote client to 7.1.8, and tried again. It still produced the error at the same spot. I then turned off compression, restarted the client, and tried again. Same error in the same spot.

It looks like some sort of time out on the remote client. I looked for a timeout setting on the client/server connection, but I didn’t see one.
Support
2014-06-24T16:59:03Z
How long time does it take to test when you do this locally?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Michael Tebbs
2014-06-24T20:42:42Z
2 minutes when testing locally. When I test remotely, the error pops at 1 minute.
Support
2014-06-25T07:47:59Z
Ok, do you mean it takes 2 minutes when the list is correctly displayed? How fast does it go when it works?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Michael Tebbs
2014-06-25T16:14:11Z
It never works remotely. When tested locally, it takes 2 minutes for the list to be displayed.
Michael Tebbs
2014-06-25T16:14:49Z
We have 151 VMs/Templates if that matters.
Support
2014-06-26T06:58:48Z
Ok, so it is just really slow. We have tried to increase the timeout in this version, please try it:

http://www.visualcron.co....aspx?g=posts&t=4160 
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Michael Tebbs
2014-06-30T15:28:02Z
It works remotely in 7.1.9. Thank you.
Support
2014-06-30T18:54:31Z
Thanks for the update!
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Scroll to Top