[6.2.2] .NET Error after reboot - VisualCron - Forum

Community forum

ErikC
  •  ErikC
  • Paid support Topic Starter
2014-06-30T08:50:12Z
Hi,

I had my 6.2.2 VC server reboot with a reboot task from a 7.1.8 VC server.
After the restart I had .NET runtime error and the service did not start.

Event Type:	Error
Event Source:	.NET Runtime 4.0 Error Reporting
Event Category:	None
Event ID:	1000
Date:		6/28/2014
Time:		11:18:16 AM
User:		N/A
Computer:	[servername]
Description:
Faulting application visualcronservice.exe, version 6.2.2.14786, stamp 5165168e, faulting module userenv.dll, version 5.2.3790.3959, stamp 45d70ac8, debug? 0, fault address 0x00001680.

and

Event Type:	Error
Event Source:	.NET Runtime
Event Category:	None
Event ID:	1026
Date:		6/28/2014
Time:		11:18:38 AM
User:		N/A
Computer:	[servername]
Description:
Application: VisualCronService.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.AccessViolationException
Stack:
   at VisualCronAPI.ImpersonationClass.LoadUserProfile(IntPtr, PROFILEINFO ByRef)
   at VisualCronAPI.ImpersonationClass.Impersonate(System.String, System.String, System.String, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, LOGON_TYPE, LOGON_PROVIDER)
   at VisualCronAPI.ImpersonationClass.Impersonate(VisualCron.NetworkCredentialClass)
   at OBOKIIHBDBPMCFALPGECCIFHCDJPEDKODDGK.DKAFLEHHMFAPJOFJIFLJPAIDDJIEENMANICP.POMGLMOALKCPPIBJEOFCDCDGENCDADIHOMKJ(VisualCron.TaskCopyFileItemClass)
   at OBOKIIHBDBPMCFALPGECCIFHCDJPEDKODDGK.DKAFLEHHMFAPJOFJIFLJPAIDDJIEENMANICP.Run()
   at System.Threading.ThreadHelper.ThreadStart_Context(System.Object)
   at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
   at System.Threading.ThreadHelper.ThreadStart()



A new reboot done from the server itself solved this issue. Don't know if the reboot task created this error, though.
Now the service runs fine. I'll check it again next weekend as the reboot is a weelky task.

Regards,
Erik
Uses Visualcron since 2006.
Support
2014-06-30T08:57:44Z
We have seen this happening in Tasks where "Load profile" is not normally needed. I would advice you to use Load user profile on Tasks where you only need desktop access like Execute Task. But if you can reproduce this we would like to try another thing to see if we can work around that.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Scroll to Top