FTP Task Issue - No files found - VisualCron - Forum

Community forum

twagner
2015-02-27T20:27:08Z
I have a FTP job that runs against a FTP server running OS/400.
VisualCron is version 7.20

The job is simply trying to list and then download any .zip files found.

No matter what I do the error output says "Exception in Task: System.Exception: No file(s) found" even though the file is there and is even found when I do a "Test" on the Remote File Filter tab of the download task within the Job.

This is the output from the FTP server.

220-QTCP at xxxxxxx.xxxxxxxxx.com.
220 Connection will close if idle more than 5 minutes.

USER xxxxx
331 Enter password.

PASS ********
230 xxxxx logged on.

FEAT
211-Feature listing follows:
AUTH TLS
CCC
PBSZ
PROT
211 End of feature listing.

SYST
215 OS/400 is the remote operating system. The TCP/IP version is "V6R1M0".

PWD
257 "QGPL" is current library.

CWD /HOME/WILTON/FLLPRODUCTS
250-NAMEFMT set to 1.
250 "/HOME/WILTON/FLLPRODUCTS" is current directory.

PWD
257 "/HOME/WILTON/FLLPRODUCTS" is current directory.

TYPE A
200 Representation type is ASCII nonprint.

PASV
227 Entering Passive Mode (172,26,96,157,126,82).

LIST
125 List started.

250 List completed.


Any suggestions?

I have the exact same job running against a windows server without issue so it makes me thing this is OS related.
Support
2015-02-28T09:34:10Z
Is it possible to provide a test account for support?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
twagner
2015-03-02T15:04:19Z
I upgraded to 7.60 over the weekend and this fixed the issue. :)

After further review it is not fixed but is inconsistent.

It gets the files most of the time but inexplicably ignores a random file every once in a while and sometimes will not get more than one file in a cycle. Other times it will get multiple files.

I am attempting to verify if thee is anything consistent in the file names that are being ignored and will post an update.
Support
2015-03-10T15:06:09Z
It sounds like the file is in use or not available every time VisualCron executes the Task. How often is the Job scheduled to run?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
twagner
2015-03-10T15:35:36Z
It runs every hour.

I though that it may be in use as well so I monitored it all day yesterday and the really strange thing is that one a file is skipped it will be skipped every time.

I have a FTP script that basically does the same thing and has run on VC for a year or more and it never has this problem. I can run it immediately after the VC job in question here does not find the file(s), and it will get the file every time.

To clarify the non script job that i am having trouble with uses all the VC functions like list, download and copy where the script does it all in a .bat file using the execute function of VC.
Support
2015-03-10T15:41:59Z
Originally Posted by: twagner 

It runs every hour.

I though that it may be in use as well so I monitored it all day yesterday and the really strange thing is that one a file is skipped it will be skipped every time.

I have a FTP script that basically does the same thing and has run on VC for a year or more and it never has this problem. I can run it immediately after the VC job in question here does not find the file(s), and it will get the file every time.

To clarify the non script job that i am having trouble with uses all the VC functions like list, download and copy where the script does it all in a .bat file using the execute function of VC.



Can you reproduce this with this specific file? If so we would like a screenshare. Turn on extended debugging in server settings->Log. This way you will see all files that are listed and download (how VisualCron sees it).
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
twagner
2015-03-10T15:45:37Z
I will send screen shots and logs soon as I have another file that it is not picking up.

Thanks!
twagner
2015-03-10T16:13:35Z
Ok So I was looking back through the log from earlier today and found this and confirmed this was a file that was being ignored.

3/10/2015 12:05:01 AM Debug OnTextDataLine (V6R1M0): ECONYERS 114688 02/23/15 10:57:58 *DIR BusinessTest/
3/10/2015 12:05:01 AM Debug Custom directory listing: 'ECONYERS 114688 02/23/15 10:57:58 *DIR BusinessTest/'
3/10/2015 12:05:01 AM Err Custom FTP parsing failed (V6R1M0): 'ECONYERS 114688 02/23/15 10:57:58 *DIR BusinessTest/'
3/10/2015 12:05:01 AM Debug JobProcessClass->TaskProcessStarted->Before enter LockWaitQueue (Sleep (5) 1)
3/10/2015 12:05:01 AM Debug OnTextDataLine (V6R1M0): LOPRECV 16886040 03/09/15 23:00:24 *STMF 15AAAAEDI.zip
3/10/2015 12:05:01 AM Debug JobProcessClass->TaskProcessStarted->Entering LockWaitQueue (Sleep (5) 1)
3/10/2015 12:05:01 AM Debug Entering wait loop. Sleep (5) 1 (1103392)
3/10/2015 12:05:01 AM Debug JobProcessClass->TaskProcessStarted->Exiting LockWaitQueue (Sleep (5) 1)
3/10/2015 12:05:01 AM Debug Custom directory listing: 'LOPRECV 16886040 03/09/15 23:00:24 *STMF 15AAAAEDI.zip'
3/10/2015 12:05:01 AM Debug JobProcessClass->TaskProcessStarted->Before enter LockWaitQueue (Sleep (5) 1)
3/10/2015 12:05:01 AM Err Custom FTP parsing failed (V6R1M0): 'LOPRECV 16886040 03/09/15 23:00:24 *STMF 15AAAAEDI.zip'
3/10/2015 12:05:01 AM Debug JobProcessClass->TaskProcessStarted->Entering LockWaitQueue (Sleep (5) 1)

Also I am on 7.61 version now.
twagner
2015-03-12T14:36:41Z
I have another instance of this.
As you can see from the Filezilla screenshot there are 3 files waiting for pickup from yesterday.
The job has picked up other files after these have been ignored. I ran the job three times with debugging on after I verified these files to exist.

I am attaching the server log and the screen shot showing their existence. Let me know if you need anything else.
It also has the "Custom FTP parsing Failed" message.



Any thoughts on this?
File Attachment(s):
log_server20150312.txt (377kb) downloaded 46 time(s).
twagner attached the following image(s):
Support
2015-03-13T16:37:38Z
Seems like we need to add some custom parsing for this FTP server. We will get back to you! Thanks for the feedback!
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Support
2015-03-19T09:04:42Z
Can you please send the log file log_serverDATE.txt to support@visualcron.com where you have this custom parse error?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
twagner
2015-03-19T13:09:27Z
The server log file is already in the thread?
Support
2015-03-19T13:38:49Z
Originally Posted by: twagner 

The server log file is already in the thread?



The problem, since it was not attached, is that duplicate blank spaces, tabs and other characters have been removed which are vital for the custom parsing.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
twagner
2015-03-19T14:15:50Z
From my end it looks like it is attached but I will do it again.

  log_server20150312.txt (377kb) downloaded 46 time(s).
Support
2015-03-19T15:27:43Z
Originally Posted by: twagner 

From my end it looks like it is attached but I will do it again.

  log_server20150312.txt (377kb) downloaded 46 time(s).



Thanks, we will look at this and get back to you.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Support
2015-03-25T12:28:06Z
twagner
2015-03-27T18:31:40Z
I am testing this version, will get back to you.

Installed the 7.64 version and tested it still doesn't find the files.

attaching the logfile.

  log_server20150318.txt (49kb) downloaded 38 time(s).
twagner
2015-04-13T15:16:12Z
This issue is solved in the 7.64 release, Thank you!
Support
2015-04-13T21:15:24Z
Thanks for the feedback!
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Scroll to Top