FTP upload - 556 Save file failed because of wrong length record - VisualCron - Forum

Community forum

itbbf
  •  itbbf
  • Paid support Topic Starter
2015-03-26T09:08:13Z
Hello,

I have a problem with FTP where the upload goes well, but saving file doesn't:

APPE xyz
150-About to open passive data connection
File:/path/file
Type:ASCII Recfm:V Lrecl: 4096
CC=ON UNIX=ON RECLF=OFF TRCC=OFF CRLF=ON NAT=NO CONT=OFF
Translate OVERRIDDEN to FS_03
MODE=Stream STRU=File
150 File status okay; about to open data connection
556 Save file failed because of wrong length record

Setting RECLF=ON possible solves the problem but there is no such option available?
(Still running 7.5.0)
Support
2015-03-26T09:58:36Z
What you can try to do is to change upload mode from ASCII to binary or otherwise depending on current mode.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
itbbf
  •  itbbf
  • Paid support Topic Starter
2015-03-26T10:40:26Z
Originally Posted by: Support 

What you can try to do is to change upload mode from ASCII to binary or otherwise depending on current mode.



I used override connection transfer mode, set it to ASCII, but no go.

APPE xyz
150-About to open passive data connection
File:/path/file
Type:ASCII Recfm:V Lrecl: 4096
CC=ON UNIX=ON RECLF=OFF TRCC=OFF CRLF=ON NAT=NO CONT=OFF
Translate OVERRIDDEN to FS_03
MODE=Stream STRU=File
150 File status okay; about to open data connection
556 Save file failed because of wrong length record

Support
2015-03-26T11:02:03Z
Originally Posted by: itbbf 

Originally Posted by: Support 

What you can try to do is to change upload mode from ASCII to binary or otherwise depending on current mode.



I used override connection transfer mode, set it to ASCII, but no go.

APPE xyz
150-About to open passive data connection
File:/path/file
Type:ASCII Recfm:V Lrecl: 4096
CC=ON UNIX=ON RECLF=OFF TRCC=OFF CRLF=ON NAT=NO CONT=OFF
Translate OVERRIDDEN to FS_03
MODE=Stream STRU=File
150 File status okay; about to open data connection
556 Save file failed because of wrong length record



Seems like it was ascii by default. Can you try changing it to binary?

Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
itbbf
  •  itbbf
  • Paid support Topic Starter
2015-03-26T11:16:07Z
Originally Posted by: Support 


Seems like it was ascii by default. Can you try changing it to binary?



Hello,
Connection tells in shared options = binary mode.

Anyways I set override to binary:

APPE xyz
150-About to open passive data connection
File:/path/file
Type:ASCII Recfm:V Lrecl: 4096
CC=ON UNIX=ON RECLF=OFF TRCC=OFF CRLF=ON NAT=NO CONT=OFF
Translate OVERRIDDEN to FS_03
MODE=Stream STRU=File
150 File status okay; about to open data connection
556 Save file failed because of wrong length record

Support
2015-03-26T11:17:54Z
Is it possible for us to get a test account for this?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
itbbf
  •  itbbf
  • Paid support Topic Starter
2015-03-26T11:26:06Z
Originally Posted by: Support 

Is it possible for us to get a test account for this?



Perhaps, I'll ask from the other side. Will get back to this later.
itbbf
  •  itbbf
  • Paid support Topic Starter
2015-03-27T10:53:23Z
Hello,
I sent by email test account details.
Cheers!
Scroll to Top