Remote Powershell Task - VisualCron - Forum

Community forum

EduardW
2015-08-06T12:26:20Z
Hi VC-Team,

i want to execute Powershell scripts remote. I think to realise that, it is important to enable remoting Powershell on remote maschine with Enable-PSRemoting CMDlet.
After i've done this, the remote powershell function in Visual Cron should work, but it doesn't.
In settings i set the right user as user and the right hostname.

2015-08-06_142324.png

The task doesn't start working if i execute him.

Is there any other thing, that i'd ignored?
Or is the mistake only possible in user- and hostname?

Would be really happy for an answer.

Best regards
Eduard
Support
2015-08-06T12:40:10Z
Which exact error do you get?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
EduardW
2015-08-06T12:47:23Z
No error.
I get two days ago with my first attempts the error:
"Could not start job as another user. The username, password or domain was incorrect. Please check your values.Exception in Task: Non zero exit code"

But i change some things like hostname, because it wasn't correctly.

If i execute the task now, the "Last Execution Time" doesn't change.

2015-08-06_144631.png
Support
2015-08-06T12:54:07Z
The user should be a user on the remote machine. If in AD you can test the Credential in the Manage Credentials window. If it works there, then deselect local logon and try to run it there. If it does not work there is a problem with username or password.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
EduardW
2015-08-06T14:43:44Z
If you mean Active Directory witz AD, no we haven't.
I testet all alternatives, with and without local logon, witz basic, default and Credssp authentification. No succes and no output from task..

The thing make me powerless, is that i tested the remote executing directly in Powershell with same server, username and password and it worked.

Powershell-Code:
Invoke-Command -ComputerName $HOSTNAME$ -ScriptBlock { PATH/TO/REMOTESCRIPT } -credential $USERNAME$

After i execute the powershell script, i have to validate the password for this user and after this the remote script starts successfully.
So i think the problem in VC doesn't depend on Hostname,Username and password.

best regards
Eduard
Support
2015-08-07T06:58:55Z
Click on Extended debugging in Server settings
Open Manage Credentials
Make sure you have Load profile checked in the Credential
Click on Test Connection - this validates the username and password.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
EduardW
2015-08-10T10:53:42Z
Hi Henrik,

thanks for the help.
I'm not sure, which settings you mean.
I think you mean these:
2015-08-10_125209.png 2015-08-10_125058.png

But where i can test the connection?

Best regards,
Eduard
ErikC
2015-08-10T11:06:59Z
For the extended logging go to:

Server [localhost] - Einstellungen - Log Settings
Check the 'Extended debug logging'.

Fot the Credetials go to:
Server [localhost] - Anmeldeinformationen
In there you will find the credentials used for your tasks.
open the right one and there is a TEST button for the credential.

Regards
Erik
Uses Visualcron since 2006.
EduardW
2015-08-10T11:22:05Z
Hi Erik,

sorry but i can't see that test button 😕
2015-08-10_132016.png

Best regards,
Eduard
ErikC
2015-08-10T11:29:14Z
Hi,

I don't know from which version this button is added. I have 7.6.3 now running and there is also no button present.
I know it is in the beta at the moment.

Regards
Erik
Uses Visualcron since 2006.
EduardW
2015-08-10T12:00:03Z
Okay 😁
I have running 7.7.2 and the button is not present, too.
So need to wait.

regards,
Eduard
Support
2015-08-11T08:08:07Z
The button are there on all versions but you need to enable Extended debugging in Server settings to see it.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Scroll to Top