Remote Task Fails intermittently - VisualCron - Forum

Community forum

Rcoyle
2015-12-17T21:26:49Z
I have been trying to resolve an issue that occurs when trying to execute a very simple *.cmd file on a remote VS server.
The *.cmd script simply writes a line to a text file. "echo SUCCESS %DATE% %TIME%.
ServerA Executes the job on ServerB via Visualcron remote task.
ServerA and ServerB are on the same network segment with no firewall between them.
I have the job set to run every 5 minutes as a test. Over a 24 hour period it may fail 10 times.
See attached screen shot of the error.
Also attached are server logs from both a successful and a failed attempt to run the run. (includes only relevant part of the log file)
This has never worked right since 1st installing Visualcron.
I have tried Versions 7.7.7, 7.7.8 and 8.0 all exhibit the same problem.
I also duplicated the environment with two separate servers. The same issue also happens here.
Has anyone else experienced this issue. In my case this is easily reproducible.
This is a very basic function of Visualcron. I find it hard to believe that I am the only person who has experienced this.
We have big plans for Visualcron in our environment however without being able to reliably able to execute a simple remote task the entire project is on hold.
Any help would be much appreciated. Visualcron on paper seems like a perfect solution to control jobs on remote servers from a single web console but so far I can't get past the most basic of functionality.

Thank you in advance

Rob Coyle (General Dynamics Health Solutions)


  Failed-job.txt (17kb) downloaded 38 time(s).  Successful-job.txt (19kb) downloaded 38 time(s).



Error Print screen.jpg
Rcoyle
2016-01-19T17:34:29Z

I was supplied with an alternate build of Version 8.0.2 yesterday which has resolved my Remote Execution issue.

Thank you VisualCron support for getting to the bottom of this.

Rob
Scroll to Top