[8.2.4] Failed jobs window - VisualCron - Forum

Community forum

ErikC
  •  ErikC
  • Paid support Topic Starter
2017-02-22T09:26:00Z
Hi Henrik,

I noticed the new Failed Jobs window which is nice, so I tested it and I have some issues with it though.

I have a job which is setup to fail every 20 seconds (oh yeah..)

I see the the red nummer go up in the ribbon which is good.
If i open the Failed Jobs window I see the errors come in every 20 seconds, which is good.
I see red exclamation marks and also hourglasses as result. They all have the same exit code though so that's strange...

Opening and closing this window shows all the new errors (comming in every 20 seconds) which is good, however it stops at 62 entries.
The red numer in the ribbon stops counting, the client is not showing that the job is running anymore, but in the server.log I can see that it does, so that is strange....

Restarting the client shows me a bigger number in the ribbon, so thats good. and it is growing every 20 seconds. It also shows more than 62 items in the list this time.

What I also noticed, I got error lines in the list from a few days before, but I have selected Days back: 1
I'm not able to reconstruct this now.
[edit]
Looks like the refresh button and the days back selection works only after closing an opening the Failed Jobs window. If I select 1 day again and refreshes the window, closing it and opening it, the errors from 1+ days back are still there.
[/edit]

[edit]
Clicking on mark all as read, removes the red number in the ribbon. Restarting the client will show the number again as if you did not click on the button.
[/edit]

Now for the grand finale:

Open the Failed Jods window and click on the 'Mark all as read' button. Close the Failed Jobs window and open it again.
Click on a line in the list and click on the red cross to close the window. The client comes in a Not Responding state (might takes a few times, but it happens) and you have to restart the client.


So it looks like there are some issues here:
  • The connection with the client and server is lost, no updates to the client anymore. Cant see my job progress, only in the server.log.
  • Error result icon in the Failed Jobs can be an hourglass or exclamation mark, why?
  • The client is non responsive after 'playing' with the new Failed Jobs window, looks to me it has to do with the mark all as read button.
  • The days back and refresh needs a close and open op the Failed Jobs window and sows wrong dates.


Regards
Uses Visualcron since 2006.
Support
2017-03-07T15:17:54Z
We will play around with it. There are some limitations currently. For example, we do not store what has been looked at so it will be fresh for each connect you do at the moment. We plan to introduce some Client settings stored at server - to make it easier for web client but it is not set in stone yet.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Gilda Dzul
2018-10-12T21:47:29Z
Erikc
I had the same issue on VC 8.3.6, I followed your steps, but didn't work. I needed to add a preivous step, clean job log and task log from database (server[localhost]/Serverđź”›/Log settings/Database settings)
"Open the Failed Jods window and click on the 'Mark all as read' button. Close the Failed Jobs window and open it again.
Click on a line in the list and click on the red cross to close the window. The client comes in a Not Responding state (might takes a few times, but it happens) and you have to restart the client."
Scroll to Top