Jobs Missing - VisualCron - Forum

Community forum

Josh
  •  Josh
  • No customer Topic Starter
2009-09-14T17:09:28Z
We had some sort of an issue over the weekend and as a result all of my VisualCron jobs are gone. The backup from 9/12/09 is also empty. From what I can tell we had a network issue late Friday that caused a script called by a VC job to hang, which caused one of the files in C:\ProgramFiles\VisualCron\tmp folder to grow unchecked until the C: drive was full. I ended up stopping the VC service and killing the script and when I reopened VC the job list was completely empty. I'm pretty sure I know the answer to this, but is there anywhere else I can look or any other way to retrieve the jobs?
Support
2009-09-14T18:46:02Z
Unfortunately not. It is strange that the backup is emtpy. We always recommend backing up on other drive/server.

Which version are you using right now?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Josh
  •  Josh
  • No customer Topic Starter
2009-09-14T18:48:42Z
5.1.6

I'm planning to upgrade today.
Support
2009-09-14T18:50:34Z
Yes, some where in 5.2.x we don't try to save if we can't. There is a risk loosing new Jobs but old Jobs are saved this way.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Josh
  •  Josh
  • No customer Topic Starter
2009-09-14T18:58:21Z
Thanks for the response. Is there a way to get hold of the default jobs - (backup and logging)?
Support
2009-09-14T19:08:43Z
Yes, either you can delete or edit the server_settings.xml. Normally, there is not anything interesting stored there (maybe SMTP settings).

<BackupJobAdded>false</BackupJobAdded>
<DeleteJobLogsAdded>false</DeleteJobLogsAdded>

You need to stop the VisualCron service before making this change. When the file is saved and service started VisualCron will add those Jobs.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Josh
  •  Josh
  • No customer Topic Starter
2009-09-14T19:20:02Z
Scroll to Top