Please note that VisualCron support is not actively monitoring this community forum. Please use our contact page for contacting the VisualCron support directly.

  •  a.a.
  • Paid support Topic Starter
In our c#.Net application we create and execute Jobs over the VisualCron API dll.
Until recently, we used version 7.6.6. After the update to version 8.3.6 the execution of the jobs does not work anymore.
The Error that we get :

Exception in Task: Not supported - old version?

The jobs is an HTTP job with one task each.
The task is created as follows
TaskClass tc = null;
string url = cmd.Trim();
tc = jc.AddTask(TaskClass.TaskT.HTTP);
tc.Name = name;
tc.HTTP.HTTPParameterType = TaskHTTPClass.HTTPParameterT.StringParameter;
tc.HTTP.Method = "GET";
tc.HTTP.URL = url;
tc.HTTP.TimeOut = taskTimeOut;
tc.HTTP.Parameters = param; // x=1&y=31.12.2020 00:00:00&z=abc

after creation a job we execut it
JobRunResultClass result = _vcServer.Jobs.Run(jobId, false, !asyn);

My first thought was that the parameters for the request are no longer set correctly and I tried to set them in the

The error still occurs. When calling Run methode. What should the exception mean and what should I exactly update .


I have now removed the value of a parameter and then added it again (marked "abc" and then simply ctrl-x ctrl-v). I did not save between cutting and adding the value! Then I started the job via context menu and it worked successfully.

I'm confused, what exactly was the problem?
Forum information
  •  a.a.
  • Paid support Topic Starter
I hope I found the cause of the error.

The only question I still have, is TaskClass.HTTP.Parameters depricated?
The value is no longer available in the client. Previously(v.7.6.6), a field parameters was under the URL. in the new version it is not there anymore
Scroll to Top