Community forum

Please note that VisualCron support is not actively monitoring this community forum. Please use our contact page for contacting the VisualCron support directly.

We have a command task that has worked but has now stopped it returns this error:
Exception in Task: Non zero exit code
Exit code (-529697949) description: VisualCronAPI.ExitCodes+ExitCodeNotFoundException: Exit code -529697949 was not found in exit code collection 'Windows.
at VisualCronAPI.ExitCodes.GetExitCodeInfo(ExitCodeCollectionClass ecc, Int32 intExitCode) in C:\sourcefiles\code\VisualCronAPI\Server\Properties\ExitCodes.vb:line 584
at VisualCronService.ExitCodeAPI.GetDescription(String strCollectionId, Int32 intExitCode) in C:\sourcefiles\code\VisualCronService\Jobs\ExitCodes\apiExitCode.vb:line 276

I'm not sure if it is Visual Cron that generates the error or the program that the task calls ( which is AltovaXML.exe).

Deos anyone have any ideas as to what exit code -529697949 means?
Forum information

we do not have any additional information from what is in Google for this. I did a quick search and some posts were talking about the working directory and some about the username containing certain characters.
Please like  VisualCron on facebook!
Thanks for the reply, you got it exactly right. It was the credentials that were a problem. This task uses only local files ( although other tasks in the job used network files with windows credentials to give accesss) as soon as I removed the credentials from this task it worked. Thanks for pointing me in the right direction
Scroll to Top