Permission denied Set job Variable task - VisualCron - Forum

Community forum

DJacobsen
2019-09-03T13:43:37Z
Hello,
We have a job that is trying to set a Job Variable in one of the tasks.
The output (error) on the job is: Permission is denied to edit variables of Job 'Process Daily DOI'

I do not see any setting on the task where a user could be selected or any way to give the job permission to edit the variable. The variable being edited is one of the variables of the job itself. This task used to work prior to us updating to 8.5.4.

What is denying permissions for a task of a job to edit the variable of that same job?
Support
2019-09-03T15:15:19Z
Originally Posted by: DJacobsen 

Hello,
We have a job that is trying to set a Job Variable in one of the tasks.
The output (error) on the job is: Permission is denied to edit variables of Job 'Process Daily DOI'

I do not see any setting on the task where a user could be selected or any way to give the job permission to edit the variable. The variable being edited is one of the variables of the job itself. This task used to work prior to us updating to 8.5.4.

What is denying permissions for a task of a job to edit the variable of that same job?



Hi, this bug should be fixed in 8.5.5 (our latest official version)

Please update to 8.5.5 and try again
Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
CAG_DS
2019-09-13T07:49:54Z
Originally Posted by: Support 



Hi, this bug should be fixed in 8.5.5 (our latest official version)

Please update to 8.5.5 and try again



Hello.

We got the same problem after upgrading to 8.5.5.

Regards
/Jesse
Support
2019-09-13T08:03:32Z
Originally Posted by: CAG_DS 

Originally Posted by: Support 



Hi, this bug should be fixed in 8.5.5 (our latest official version)

Please update to 8.5.5 and try again



Hello.

We got the same problem after upgrading to 8.5.5.

Regards
/Jesse



Could you contact us at support@visualcron.com with screenshots of the task/variable that gives you this error ? Or better, if you could export a simple version of that job (clone it and then simplify it) for us to reproduce this, so we can see if it is a bug in 8.5.5 or some other issue.
Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
CAG_DS
2019-09-13T14:10:58Z
Originally Posted by: Support 



Could you contact us at support@visualcron.com with screenshots of the task/variable that gives you this error ? Or better, if you could export a simple version of that job (clone it and then simplify it) for us to reproduce this, so we can see if it is a bug in 8.5.5 or some other issue.



It's difficult to send you this material since the problem is very inconcistant.
I've got about 30 jobs that has "Job/Task control" tasks in them.
5 of them gets errors in the child-job. They get authorization problems but in different kind of tasks and not always the first task in the child-job.
When I manually reruns the jobs from the failing task they run successfully.
My theory is that it has something to do with "Update Job Variable" or "Translate Variables before sending".
I've unchecked those boxes and will see the result on monday morning.
In one of the failing jobs I've recreated the job/Task Control-task to see if it has inherited something that affects this.

I will get back to you after the weekend.
Regards
/Jesse
Support
2019-09-13T16:23:47Z
Originally Posted by: CAG_DS 

Originally Posted by: Support 



Could you contact us at support@visualcron.com with screenshots of the task/variable that gives you this error ? Or better, if you could export a simple version of that job (clone it and then simplify it) for us to reproduce this, so we can see if it is a bug in 8.5.5 or some other issue.



It's difficult to send you this material since the problem is very inconcistant.
I've got about 30 jobs that has "Job/Task control" tasks in them.
5 of them gets errors in the child-job. They get authorization problems but in different kind of tasks and not always the first task in the child-job.
When I manually reruns the jobs from the failing task they run successfully.
My theory is that it has something to do with "Update Job Variable" or "Translate Variables before sending".
I've unchecked those boxes and will see the result on monday morning.
In one of the failing jobs I've recreated the job/Task Control-task to see if it has inherited something that affects this.

I will get back to you after the weekend.
Regards
/Jesse



This could be that you have different versions between server and client. Could you check that please?

Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
CAG_DS
2019-09-16T13:07:21Z
Originally Posted by: Support 



This could be that you have different versions between server and client. Could you check that please?



Hello again.
We have the same version on both client and server installations, so that is not the reason.

We experience different errors on different types of tasks.
The thing that is consistant is that it's allways a "Job/Task control" task that starts a new job.
The child job always seems to be failing with some kind of authority problem, no matter what kind of task or order in the child job.

Could it be a memory leakage or something of that sort?

/Jesse
Support
2019-09-19T10:19:14Z
Originally Posted by: CAG_DS 

Originally Posted by: Support 



This could be that you have different versions between server and client. Could you check that please?



Hello again.
We have the same version on both client and server installations, so that is not the reason.

We experience different errors on different types of tasks.
The thing that is consistant is that it's allways a "Job/Task control" task that starts a new job.
The child job always seems to be failing with some kind of authority problem, no matter what kind of task or order in the child job.

Could it be a memory leakage or something of that sort?

/Jesse



Can you export this to us please? As simple as possible, one task with job/task control and one task with set variable and mail it to us at support@visualcron.com so we could try to reproduce this

Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
Scroll to Top