Powershell Task and job at 99% - VisualCron - Forum

Community forum

v.dahlem
2019-09-17T09:52:59Z
Hello,

A VCron Job is executing a unique Task (PowerShell) (which call a Talend Job)
The PowerShell task and the job are generally executing fine.
But a special case has occurred :
the task has finished OK and the Job stay at 99% indefinitely.
"Stop task" was the only way.

Any ideas, please ?
al355
2019-09-17T16:24:28Z
Which version of Visual Cron is this on?
v.dahlem
2019-09-18T07:15:11Z
The version of Visual Cron : 8.5.4
Support
2019-09-19T10:15:52Z
Originally Posted by: v.dahlem 

Hello,

A VCron Job is executing a unique Task (PowerShell) (which call a Talend Job)
The PowerShell task and the job are generally executing fine.
But a special case has occurred :
the task has finished OK and the Job stay at 99% indefinitely.
"Stop task" was the only way.

Any ideas, please ?



Hi, can you test this script please
[System.Security.Principal.WindowsIdentity]::GetCurrent().Name

If that works in your task, then please look at your script and break it down row by row to try to find where it causes an error for you.

Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
v.dahlem
2019-09-19T12:50:56Z
As i said higher : "The PowerShell task and the job are generally executing fine"
So, difficult to reproduce the case.
David A
2019-09-20T17:51:14Z
Originally Posted by: v.dahlem 

Hello,

A VCron Job is executing a unique Task (PowerShell) (which call a Talend Job)
The PowerShell task and the job are generally executing fine.
But a special case has occurred :
the task has finished OK and the Job stay at 99% indefinitely.
"Stop task" was the only way.

Any ideas, please ?



I have been having this issue on 8.5.4 as well. The Job is at 99%, shows in "Running jobs" with the Windows PID (process has already exited and no longer exists on the server). In my case, it seems as if VC is missing the termination.
Support
2019-09-23T15:29:59Z
Originally Posted by: David A 

Originally Posted by: v.dahlem 

Hello,

A VCron Job is executing a unique Task (PowerShell) (which call a Talend Job)
The PowerShell task and the job are generally executing fine.
But a special case has occurred :
the task has finished OK and the Job stay at 99% indefinitely.
"Stop task" was the only way.

Any ideas, please ?



I have been having this issue on 8.5.4 as well. The Job is at 99%, shows in "Running jobs" with the Windows PID (process has already exited and no longer exists on the server). In my case, it seems as if VC is missing the termination.



Please enable "Enable extended task debugging" in the main window of the task, and when it happens send us the log_server*CurrentDate* which you can find if you right-click on the tray-icon then --> Server --> Open log folder

and tell us the job name, task name and time when it occurred. Also, if possible, export the job as well, send this to support@visualcron.com and we will investigate it and get back to you asap.
Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
Scroll to Top