Powershell - option for IncludePortInSPN when remoting and ConfigurationName - VisualCron - Forum

Community forum

When remoting into computers using powershell where the target computer run IIS or other processes as a user on port 80 the error below occurs. This is standard behavior and in order to connect anyway you have to use the pssessionoption IncludePortInSPN, but that option is not available in VisualCron thereby making remoting more complex than it has too. A field for ConfigurationName would also be appreciated when Powershell 7 becomes the standard so that you can remote into a Powershell 7 session on a remote computer using 'powershell.7' as the configuration name when Powershell 7 is installed and configured correctly for remoting on the remote computer - otherwise it will default to Windows powershell 5.1


Enter-PSSession: Connecting to remote server myserver failed with the followi
ng error message : WinRM cannot process the request. The following error with er
rorcode 0x80090322 occurred while using Kerberos authentication: An unknown secu
rity error occurred.
Possible causes are:
-The user name or password specified are invalid.
-Kerberos is used when no authentication method and no user name are specified
-Kerberos accepts domain user names, but not local user names.
-The Service Principal Name (SPN) for the remote computer name and port does n
ot exist.
-The client and remote computers are in different domains and there is no trus
t between the two domains.
After checking for the above issues, try the following:
-Check the Event Viewer for events related to authentication.
-Change the authentication method; add the destination computer to the WinRM T
rustedHosts configuration setting or use HTTPS transport.
Note that computers in the TrustedHosts list might not be authenticated.
-For more information about WinRM configuration, run the following command: w
inrm help config. For more information, see the about_Remote_Troubleshooting Hel
p topic.

Scroll to Top