Unable to execute SSIS package using SSIS task- Page 2 - VisualCron - Forum

Community forum

Support
2010-04-06T20:32:53Z
Interesting. We are writing a temporary file to the tmp folder of VisualCron folder. Maybe that is the problem. Do you have any restricted right writing to that folder?

Anyway, we will create a new version that uses other folder for writing.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
JohnC
  •  JohnC
  • Free support Topic Starter
2010-04-06T20:37:14Z
I found that if I try to run my "empty" SSIS package with no credentials, the package completes successfully. If I add a database connection, and then try to run that package without specifying a credential, the package fails because of the failed log in for the database connection. If I then specify a credential to be used for the task (the same credential required by the database connection within the SSIS package), the package fails with the "Access is Denied" error.

How is the credential being passed to the package?
Support
2010-04-06T20:39:55Z
A new process is started with the correct Credentials. This process runs the SSIS Task. Seems like it can't start this process with those Credentials.

Is it a domain account that you are using?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
JohnC
  •  JohnC
  • Free support Topic Starter
2010-04-06T20:41:11Z
Yes, I am using a domain account.
Support
2010-04-06T20:54:41Z
We will get back to you regarding the Access denied. Thank you for your patience. We will have a solution for tomorrow.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
JohnC
  •  JohnC
  • Free support Topic Starter
2010-04-06T21:17:47Z
I hope you can figure this out. This issue is very frustrating.
Support
2010-04-07T11:28:17Z
Please uninstall current and re-download this:

http://neteject.com/down...Cron/VisualCron5.5.6.exe 
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
JohnC
  •  JohnC
  • Free support Topic Starter
2010-04-07T15:12:47Z
Well - At least I'm getting more information on the failed task (though it is still failing).

After installing the new version, I created a new job that runs a "test" SSIS package. The package contains one database connection (named "Lawson") and a SQL task that performs a record count on a single table.

The VisualCron job is using the same credential that is required by the database connection within the SSIS package. This credential consists of a domain user ID and password.

Here is the error I am getting when the VC task fails:

The SSIS Execution failed

Number of warnings: 1
Warning (0):SSIS Warning Code DTS_W_MAXIMUMERRORCOUNTREACHED. The Execution method succeeded, but the number of errors raised (1) reached the maximum allowed (1); resulting in failure. This occurs when the number of errors reaches the number specified in MaximumErrorCount. Change the MaximumErrorCount or fix the errors.

Number of errors: 2

Error (0):SSIS Error Code DTS_E_OLEDBERROR. An OLE DB error has occurred. Error code: 0x80040E4D.
An OLE DB record is available. Source: "Microsoft SQL Server Native Client 10.0" Hresult: 0x80040E4D Description: "Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'.".

Error (1):Failed to acquire connection "LAWSON". Connection may not be configured correctly or you may not have the right permissions on this connection.

From, GetErrorValues (0)

Exception in Task: Non zero exit code
Exception in Task:


Based on the error, it seems like VisualCron is not passing the credential to the SSIS package.
Support
2010-04-07T16:35:00Z
Thanks for the input. Can you uninstall one more time and re-download the same file again (from the link).
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
JohnC
  •  JohnC
  • Free support Topic Starter
2010-04-07T18:06:23Z
I uninstalled and reinstalled a fresh copy of VC per your instructions. The SSIS job is still failing but the output has changed:

CancelEvent = 1432
ContainerStartTime = 4/7/2010 11:03:52 AM
CreationDate = 4/6/2010 1:23:11 PM
CreatorComputerName = WCHLAW9APP01
CreatorName = PRO1S\SQL_Lawson_Interface
ExecutionInstanceGUID = {3225A67C-8A13-4187-A446-9634E6FCBA3B}
FailedConfigurations =
InteractiveMode = False
LastModifiedProductVersion = 10.0.1600.22
LocaleID = 1033
MachineName = WCHLAW9APP01
OfflineMode = False
PackageID = {7A3083E7-D2E5-47D5-8509-A70985FD178B}
PackageName = Test
ParentContainerGUID =
ProductVersion = 10.0.1600.22
StartTime = 4/7/2010 11:03:52 AM
UserName = PRO1S\SQL_Lawson_Interface
VersionBuild = 7
VersionComments =
VersionGUID = {823F27B1-46B4-4073-8C14-7A08EE293644}
VersionMajor = 1
VersionMinor = 0
Support
2010-04-07T18:07:11Z
Is this in the error or normal output?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
JohnC
  •  JohnC
  • Free support Topic Starter
2010-04-07T18:14:05Z
This is in the normal output. The stderr output only shows "Exception in Task:" and nothing else.
Support
2010-04-07T18:15:17Z
We will check. Are you able to get any debugging from the server itself - what failed?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
JohnC
  •  JohnC
  • Free support Topic Starter
2010-04-07T18:25:29Z
I don't see anything in the server event logs that indicate why the VC job failed.
Support
2010-04-07T18:26:15Z
It seems like it did not fail according to the output. Are you sure it failed (even though VisualCron reported so)?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
JohnC
  •  JohnC
  • Free support Topic Starter
2010-04-07T18:44:23Z
Henrik - I'm glad you asked me to check the SSIS packages. I've verified that the SSIS packages are executing correctly. It's just that VisualCron is reporting an error. I verified this by adding an e-mail task to my test SSIS package and I received the e-mail correctly.

I also tested another VC job that contains two SSIS package tasks. When I run the job, I can verify the first SSIS package executes correctly. But since VC reports an error with the task, the second SSIS package task does not execute. However, if I run the second task manually, I again can verify that the SSIS package executes correctly even though VC reports an error on the task.

I'm happy to see we are getting closer!
Support
2010-04-07T18:47:36Z
Thanks for the update. We will look through the process to see why it is reporting an error anyway.

I wonder if it is possible to ask you of a big favor. We currently do not have any simple SSIS package that we could test with and we do wonder if you could create the simplest package for us. I don't know if it is possible to create a package just with a function (and no connection) or create a package that uses default master databases in query or similar. We would really appreciate this and that would help us to debug.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Support
2010-04-07T19:07:47Z
Could you try one more time to reinstall with same link?

Hopefully the error disappears or we get more information in the std err column.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
JohnC
  •  JohnC
  • Free support Topic Starter
2010-04-07T20:47:29Z
Henrik - I again uninstalled and installed the latest version of the VC software per your instructions. The error remains, VC reports tasks errors even thought the SSIS packages are executing correctly.

I created a simple SSIS package that checks for the existence of a file (c:\temp\test.txt). How can I get this dtsx file to you for testing?
Support
2010-04-07T20:54:26Z
Please send it to support@visualcron.com . Thanks
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
JohnC
  •  JohnC
  • Free support Topic Starter
2010-04-07T20:59:37Z
E-mail message sent. Please let me know if you have any problems with the dtsx file attachment. Thanks.
JohnC
  •  JohnC
  • Free support Topic Starter
2010-04-08T18:02:01Z
Any update on this issue? I'm now having problems with jobs wanting to open "empty" interactive DOS windows waiting for a response, even though the jobs are set to run in the background. None of these jobs have been modifed so I ahve to assume it's a problem with the latest release you had me download and install.
Support
2010-04-08T18:05:09Z
Hi again,

we just posted a new version (same download).

Thank you for your file but we had some problems with it as well. We assume the reason is that our environment is not setup correctly.

Please test the latest version.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
JohnC
  •  JohnC
  • Free support Topic Starter
2010-04-08T21:52:38Z
SUCCESS!!!! I am now able to execute SSIS packages using the SSIS task in VisualCron. The jobs complete successfully and VisualCron reports the same.
Support
2010-04-08T22:09:13Z
Great! Thanks for the feedback and patience regarding this matter. We are sorry if it was a lot of back and forth but we had to redo this Task completely.

Please let us know if you find anything else.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Scroll to Top