7.5.2 - VisualCron - Forum

Community forum

Support
2014-11-19T09:46:47Z
Changes so far:

Changes in 7.5.2

[NOTE] All: New protocol version (7.5.2) for communication. Requires Server and Client version to be the same.
[FEATURE] Server: HTTP Task->Now resolving "Content-Disposition" to get name of file attachments downloaded
[FEATURE] API/Client/Server: Changed the way VisualCron communicates to improve speed and stability
[FEATURE] Client/Server: Connections->SQL Connection test is now performed from Server instead of Client giving more exact result (also with Credential option)
[FEATURE] Client/Server: Connections->WebDAV->Added support for SSL/TLS version support
[FEATURE] Client/Server: FTP/SFTP->Download->Added support for replacing unsupported Windows characters
[FEATURE] Client/Server: Variables->Any non-letter character can be used as parameter split character. Start by using the first character in argument that you want to use, for example: {FILE(@Content@c:\textfile.txt)}
[FEATURE] Client/Server: Web service Task->Added custom endpoint option to override any existing end point
[BUGFIX] Server: PowerShell Task->Handling large output error "The maximum string content length quota (8192) has been exceeded while reading XML data."
[BUGFIX] Client: Import settings->Fixed a problem when trying to import all settings when only some settings selected
[BUGFIX] Client: FTP Explorer->Fixed handling of Binary/ASCII setting
[BUGFIX] Client: Credentials->Fixed alphabetical sorting in combos
[BUGFIX] Client: Grid filter->Handled a problem with backslashes in the grid filter
[BUGFIX] Server: Excel - Create Task->Fixed a problem with creating password encrypted file
[BUGFIX] Server: Archive - Decompress->Fixed a memory leak while extracting
[BUGFIX] API/Client/Server: Fixed a problem calculating next run of Trigger on invalid dates
[BUGFIX] Server: Web service Task->Fixed a problem executing certain web services
[BUGFIX] Server: PowerShell Task->Fixed a problem with Variables not resolving in parameters
[BUGFIX] Client: Variables->Fixed a problem changing name of cloned Variable
[BUGFIX] Server: Delete files Task->Fixed a problem with deleting empty sub folders
[BUGFIX] API: AD->Timeout increased on AD queries
[BUGFIX] Server: Job report Task->Fixed encoding and various issues
[BUGFIX] Server: SSISDB Task->Now translating Connection string Variables properly
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Support
2014-12-03T18:05:06Z
New build, changes:

[NOTE] All: New protocol version (7.5.2) for communication. Requires Server and Client version to be the same.
[FEATURE] API/Client/Server: Changed the way VisualCron communicates to improve speed and stability
[BUGFIX] FTP Explorer: Fixed handling of Binary/ASCII setting
[BUGFIX] Credentials: Fixed alphabetical sorting in combos
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Support
2014-12-08T13:36:41Z
New build, changes:

[BUGFIX] Grid filter: Handled a problem with backslashes in the grid filter
[BUGFIX] Excel - Create Task: Fixed a problem with creating password encrypted file
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
ErikC
2014-12-09T07:31:28Z
Hi,

After installing over the previous build of 7.5.2, I don't see any jobs.

[edit]
  1. After a reboot of the server, there are still no jobs;
  2. Looks like I don't have permissions anymore with the VC admin account
  3. uninstalling and reinstalling did not solve the permission issue: 'You don't have permission to perform this action.' I think there is a permission problem in this latest beta release.
  4. Back to 7.5.1: my jobs are back an I do have permissions with the VC admin user.
[/edit]


Regards,
Erik
Uses Visualcron since 2006.
Support
2014-12-09T11:08:08Z
Originally Posted by: ErikC 

Hi,

After installing over the previous build of 7.5.2, I don't see any jobs.

[edit]

  1. After a reboot of the server, there are still no jobs;
  2. Looks like I don't have permissions anymore with the VC admin account
  3. uninstalling and reinstalling did not solve the permission issue: 'You don't have permission to perform this action.' I think there is a permission problem in this latest beta release.
  4. Back to 7.5.1: my jobs are back an I do have permissions with the VC admin user.
[/edit]


Regards,
Erik



Are you using AD logon or? Which version did you upgrade from?
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
ErikC
2014-12-09T12:50:55Z
Hi I was upgrading from the previous beta 7.5.2.
I have only the default admin user here.

I uninstaled the new beta version, deleted the left over folder structure an installed to the same path again, fresh, no upgrade. Same issue. Loggin in with the admin (no password) gives me no jobs and clicking on an menu button gives me te privilages error.

Do the uninstall again as above and installing 7.5.1 works fine.

Regards,
Erik
Uses Visualcron since 2006.
Support
2014-12-09T16:19:02Z
Originally Posted by: ErikC 

Hi I was upgrading from the previous beta 7.5.2.
I have only the default admin user here.

I uninstaled the new beta version, deleted the left over folder structure an installed to the same path again, fresh, no upgrade. Same issue. Loggin in with the admin (no password) gives me no jobs and clicking on an menu button gives me te privilages error.

Do the uninstall again as above and installing 7.5.1 works fine.

Regards,
Erik



Unfortunately we cannot reproduce this on any of our machines right now. We will upload a new build soon.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Support
2014-12-09T16:19:57Z
New build, changes:

[BUGFIX] Archive - Decompress: Fixed a memory leak while extracting
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
ErikC
2014-12-10T07:26:49Z
Originally Posted by: Support 

Unfortunately we cannot reproduce this on any of our machines right now. We will upload a new build soon.


New build tested, had the same result:

I can connect with admin (same user as 7.5.1) , but I do not see my jobs. All the ribbon buttons gives me the permission error. Shall I send you my configuration?

Regards,
Erik


Uses Visualcron since 2006.
Support
2014-12-10T10:02:17Z
Originally Posted by: ErikC 

Originally Posted by: Support 

Unfortunately we cannot reproduce this on any of our machines right now. We will upload a new build soon.


New build tested, had the same result:

I can connect with admin (same user as 7.5.1) , but I do not see my jobs. All the ribbon buttons gives me the permission error. Shall I send you my configuration?

Regards,
Erik



Yes, please zip the files in the settings folder and send to us.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Support
2014-12-10T14:00:11Z
New build, changes:

[BUGFIX] API/Client/Server: Fixed a problem calculating next run of Trigger on invalid dates
[BUGFIX] Server: Web service Task->Fixed a problem executing certain web services
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
ErikC
2014-12-12T08:34:25Z
Hi,

With the new build I still have the empty jobs issue. I send you some logs. I hope this will help you catch this issue.

Now with having the persmission issue, I clicked on the Server info button in the ribben and I received an error:

System.NullReferenceException: Object reference not set to an instance of an object.
   at frmServerInfo.KHMBAFFGDLMOJEDPOPOEEODNDEKILNDIBOBM(Boolean  ) in C:\sourcefiles\code\VisualCron\Settings\frmServerInfo.vb:line 21
   at frmServerInfo.CBDACPJFPCDOJCDAFLHOCLDMEMGAAOMGCKPG(Object  , EventArgs  ) in C:\sourcefiles\code\VisualCron\Settings\frmServerInfo.vb:line 12
   at System.Windows.Forms.Form.OnLoad(EventArgs e)
   at System.Windows.Forms.Form.OnCreateControl()
   at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
   at System.Windows.Forms.Control.CreateControl()
   at System.Windows.Forms.Control.WmShowWindow(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   at System.Windows.Forms.Form.WmShowWindow(Message& m)
   at System.Windows.Forms.Form.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


Regards
Erik
Uses Visualcron since 2006.
Support
2014-12-14T11:38:49Z
New build, changes:

+ should fix the permissions issue
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
ErikC
2014-12-15T08:00:16Z
Originally Posted by: Support 

New build, changes:

+ should fix the permissions issue

Yes, this fixed my issue!
Big thank you!

Regards,
Erik
Uses Visualcron since 2006.
Support
2014-12-16T12:55:07Z
New build, changes:

+ added debugging for new communication
+ added a potential fix for a memory leak in file trigger
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
jshoebrook
2015-01-06T19:35:59Z
Is there a release date for 7.5.2?
Support
2015-01-14T09:00:41Z
New version, changes:

+updated SMTP components


Quote:

Is there a release date for 7.5.2?



This version will likely be released on Friday.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Support
2015-01-16T14:29:54Z
New build, changes:

+ fixed issue showing log window
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Lucky Thor 2013
2015-01-19T10:38:53Z
Hi Henrik,
I have exact same issue on Win 8.1.
After auto upgrade to version 7.5.2 this morning .. can no longer see jobs and cannot start connection to localhost.
Lucky Thor 2013
2015-01-19T10:46:09Z
Henrik,
Where can I find a copy of VisualCron which does not have these Active Directory 'improvements'? I think you mention v7.2.1 is a good regression point.
Many thanks
Dave
Support
2015-01-21T22:47:57Z
Originally Posted by: Lucky Thor 2013 

Henrik,
Where can I find a copy of VisualCron which does not have these Active Directory 'improvements'? I think you mention v7.2.1 is a good regression point.
Many thanks
Dave



Temporarily, version 7.5.1. has been re-instated on the download page so you can download that version.

Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Support
2015-01-22T10:28:32Z
New build, changes:

[BUGFIX] Server: PowerShell Task->Fixed a problem with Variables not resolving in parameters
[BUGFIX] Client: Variables->Fixed a problem changing name of cloned Variable
[FEATURE] Client/Server: Connections->SQL Connection test is now performed from Server instead of Client giving more exact result (also with Credential option)
[FEATURE] Client/Server: Connections->WebDAV->Added support for SSL/TLS version support
+ fix for multi server connect crash
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Support
2015-01-23T15:04:05Z
New build, changes:

+ fixes in communication issues
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Support
2015-01-24T13:52:45Z
New build, changes:

+ fixes in Job date issues because of new communication
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Support
2015-01-26T09:19:58Z
New build, changes:

+ fixes in Job result issues because of new communication
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Scroll to Top