issuese with Oracle Database connection in VisualCron - VisualCron - Forum

Community forum

tozier
2019-01-24T14:56:16Z
Good Day,

We have issues trying to configure an Oracle Database connection in VisualCron

OS: Windows Server 2016 Standard 64bits
VisualCron Client/Server: 32bits v8.2.8 Build 42562 (2017-07-31 23:38:48)
Oracle Client: 32bits v12.1.0.2.4

Steps to reproduce:
- Open VisualCron Client 8.2.8
- In the 'Server [localhost]' tab, go to 'Connections'
- Click the 'Add' dropdown and select 'SQL'
- Choose 'Use connection guide' option
- Select the following options and click 'Next':
Storage type -> Database
Database type -> Oracle
Data provider -> Native
- Set the following options
Connection type -> Standard
Data Source -> (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=*****)(PORT=1521))(CONNECT_DATA=(SID=*****)))
User Id -> *****
Password -> *****
- Click 'Test connection'

We get the following error message:
Connection test failed. Error: Unable to load C:\Oracle\product\12.1.0\client_1\oci.dll. Please check that you use 64x version of Oracle client with 64x application.

C:\Oracle\product\12.1.0\client_1\oci.dll exists on the filesystem.
Both VisualCron and the Oracle client are 32 bits
The connection string works fine when used in the code of console applications run by VisualCron
Creating and testing a MSSQL connection works fine.

What can we do to solve this issue?

Thank you,
Best Regards.
J.
Support
2019-01-24T22:28:20Z
Use the Oracle direct mode without the need of any Clients.

Oracle->Native->Standard 2- direct mode connection string
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Scroll to Top