Community forum

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
View
Go to last post Go to first unread
Offline rayudu  
#1 Posted : Monday, February 25, 2019 6:31:48 PM(UTC)
rayudu

Rank: Paid support

Joined: 8/16/2018(UTC)
Posts: 12

Thanks: 4 times
Hello,

We have recently updated Visual cron from 7.7.3 to 8.4.1. But many of our tasks are getting crashed. So, we decided to rollback to 7.7.3 version.

Now, we have few queries

1. Is there any specific process to be followed to downgrade from 8.4.2 to 7.7.3?
2. Will just uninstall the latest-present version and running the installer for 7.7.3 pointing to same installation path works or does this cause any issues?
3. Any changes to settings / tasks files between those versions?
4. When will the new version 8.4.2 (Official - not beta) with all of these bug fixes get released.? Our IT wont approve for beta versions. We only need official version.
Offline rayudu  
#2 Posted : Tuesday, February 26, 2019 2:36:20 PM(UTC)
rayudu

Rank: Paid support

Joined: 8/16/2018(UTC)
Posts: 12

Thanks: 4 times
VisualCron team,

We are waiting for your response to plan our activity in server where we have critical works. Please update the steps ASAP
Offline Support  
#3 Posted : Tuesday, February 26, 2019 4:54:08 PM(UTC)
Support

Rank: Official support

Joined: 2/23/2008(UTC)
Posts: 11,223

Thanks: 875 times
Was thanked: 446 time(s) in 424 post(s)
1. preferably you should backup before you upgrade as new settings files might not be backwards compatible. So find an old backup if you get problems downgrading. Downgrading just involves installing older version on top: https://www.visualcron.com/oldversions.aspx
2. correct
3. yes, many, 7.7.3 is a very old version (please refer to 1)
4. 2-3 weeks. But what is your issue specifically?
Henrik
Support
http://www.visualcron.com
Please like VisualCron on facebook!
Offline rayudu  
#4 Posted : Tuesday, February 26, 2019 5:24:39 PM(UTC)
rayudu

Rank: Paid support

Joined: 8/16/2018(UTC)
Posts: 12

Thanks: 4 times
My problem is about macro jobs keep on running but no result - Even after uncheck of CallQuit option.
And some inactive tasks getting triggered automatically.

Confirm if following steps are correct and both cases works:

Case-A: I have not taken backup

Steps:
1. Uninstall 8.4.1(existing version)
2. Cut everything from Settings folder of installation directory.
3. Install old version 7.7.3 using same old installation directory where settings folder is clear now
4. Now import jobs from VC-Settings.zip which VC creates before uninstalling


Case-B : I have backup of full Visualcron folder from installation dir before uninstall

Steps:
1. Uninstall 8.4.1(existing version)
2. clear the installation dir now.
3. Paste all the folders into installation directory from backup -
a. Let me know if we need to replace complete folder or just settings folder works?
b. Or should we need to just import the settings(after old version install).
4. Install version 7.7.3 now.?

Correct the steps in both the cases A&B.

Offline Support  
#5 Posted : Tuesday, February 26, 2019 6:15:49 PM(UTC)
Support

Rank: Official support

Joined: 2/23/2008(UTC)
Posts: 11,223

Thanks: 875 times
Was thanked: 446 time(s) in 424 post(s)
A backup is preferably not a backup of the folder but Client->File menu->Export. So please export that way as backup.

Only import settings if startup fails (without Jobs).

If you do not have any 7.7.3 backup file or directory there is a big risk downgrading. Try finding old folder backup and if you have that you can install 7.7.3 then stop the service, then replace files, then start the service.
Henrik
Support
http://www.visualcron.com
Please like VisualCron on facebook!
thanks 1 user thanked Support for this useful post.
rayudu on 2/27/2019(UTC)
Offline rayudu  
#6 Posted : Wednesday, February 27, 2019 2:35:54 PM(UTC)
rayudu

Rank: Paid support

Joined: 8/16/2018(UTC)
Posts: 12

Thanks: 4 times
I checked and I have backup - both folders and also File Menu -> Export.

So, please confirm what to do. I need to be more clear on steps.

1...
just uninstall 8.4.1, install 7.7.3 and then check if jobs appear - If yes, leave it. If no, Stop VisualCron service, from installation directory, remove all files, place backup files ; then start service

2..
just uninstall 8.4.1, install 7.7.3 and then check if jobs appear - If yes, leave it. If no, Stop VisualCron service, import vc-settings.zip from previous backup ; and then to start the service.


Confirm whether both of above works or any single option?
Offline Support  
#7 Posted : Wednesday, February 27, 2019 3:43:35 PM(UTC)
Support

Rank: Official support

Joined: 2/23/2008(UTC)
Posts: 11,223

Thanks: 875 times
Was thanked: 446 time(s) in 424 post(s)
It depends if you have backup.zip from 7.7.3. If yes, then do 2. If no, do 1.
Henrik
Support
http://www.visualcron.com
Please like VisualCron on facebook!
thanks 1 user thanked Support for this useful post.
rayudu on 2/27/2019(UTC)
Users browsing this topic
Guest (2)
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Scroll to Top