SQL Explorer: Oracle connections give error - VisualCron - Forum

Community forum

Jon Tofte-Hansen
2020-01-21T10:12:19Z
Experienced on server/client 9.1 and 9.0.

I get a "License not found" (Devart) error when I try to open connections to Oracle databases in SQL Explorer:
SQL_Explorer_Oracle_Error.png

The Oracle connections work in SQL tasks.
MS SQL Server connections work as expected in SQL Explorer.
Support
2020-01-21T11:57:12Z
Originally Posted by: Jon Tofte-Hansen 

Experienced on server/client 9.1 and 9.0.

I get a "License not found" (Devart) error when I try to open connections to Oracle databases in SQL Explorer:
SQL_Explorer_Oracle_Error.png

The Oracle connections work in SQL tasks.
MS SQL Server connections work as expected in SQL Explorer.



Can you show screenshots of your connection settings? either here or mail to support@visualcron.com
Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
Jon Tofte-Hansen
2020-01-21T13:36:29Z
With generalized parameters:
SQL_Explorer_Oracle_Error2.png

OS is Win 2019 standard.
Support
2020-01-21T23:03:05Z
Thanks for the report. We will look at this tomorrow.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Support
2020-01-22T18:56:43Z
Please test this build and let us know: https://www.visualcron.c....aspx?g=posts&t=9855 
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Jon Tofte-Hansen
2020-01-23T10:12:08Z
Hmm, that is worse! Now the Oracle connections doesn't work at all.

I cannot get the file upload to work but this is some errors (running a task, testing a connection, opening connection in SQL Explorer):


Exception in Task: License not found. Please view "Licensing" topic in dotConnect Universal documentation for details or contact Devart technical support.

Connection test failed. Error: License not found. Please view "Licensing" topic in dotConnect Universal documentation for details or contact Devart technical support.

System.ArgumentException: License not found. Please view "Licensing" topic in dotConnect Universal documentation for details or contact Devart technical support.
at Devart.Data.Universal.UniConnection.c()
at Devart.Data.Universal.UniConnection.Open()
at DataAccess.DatabaseObjects(String ConnectionID, Boolean& Success, VariableReplacerClass VR) in C:\git\code\VisualCron\SQL Explorer\BusinessLogic\DataAccess.vb:line 1622
DatabaseObjects
at Devart.Data.Universal.UniConnection.c()
at Devart.Data.Universal.UniConnection.Open()
at DataAccess.DatabaseObjects(String ConnectionID, Boolean& Success, VariableReplacerClass VR) in C:\git\code\VisualCron\SQL Explorer\BusinessLogic\DataAccess.vb:line 1622
Support
2020-01-23T17:42:30Z
Please try to re-download and re-install again: https://www.visualcron.c....aspx?g=posts&t=9855 
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Jon Tofte-Hansen
2020-01-30T08:16:36Z
Hi. I apparently missed a notification (and had some other stuff to do), so I didn't see the latest reply until now, sorry.

With the latest version downloaded now the ordinary connections work again but the Connection Explorer against Oracle connections is stil not working.

Error:
System.ArgumentException: License not found. Please view "Licensing" topic in dotConnect Universal documentation for details or contact Devart technical support.
at Devart.Data.Universal.UniConnection.c()
at Devart.Data.Universal.UniConnection.Open()
at DataAccess.DatabaseObjects(String ConnectionID, Boolean& Success, VariableReplacerClass VR) in C:\git\code\VisualCron\SQL Explorer\BusinessLogic\DataAccess.vb:line 1622
DatabaseObjects
at Devart.Data.Universal.UniConnection.c()
at Devart.Data.Universal.UniConnection.Open()
at DataAccess.DatabaseObjects(String ConnectionID, Boolean& Success, VariableReplacerClass VR) in C:\git\code\VisualCron\SQL Explorer\BusinessLogic\DataAccess.vb:line 1622
Jon Tofte-Hansen
2020-02-06T14:44:12Z
Support
2020-02-07T08:11:58Z
We cannot reproduce this with the latest build. Please export your Job and the Connection and send to support@visualcron.com. You can of course update any password before exporting.
Henrik
Support
http://www.visualcron.com 
Please like  VisualCron on facebook!
Support
2020-02-12T12:18:05Z
This is now solved in our latest build (9.1.5)
Michael
Support
http://www.visualcron.com 

Please like  VisualCron on facebook!
Scroll to Top