Please note that VisualCron support is not actively monitoring this community forum. Please use our contact page for contacting the VisualCron support directly.

I'm very new so I apologize in advance for any etiquette violations. I searched the forum as best as I could and also tried the help documents but I am unable to trouble shoot the following issue.

Issue: I cannot get VC to use a local HTTP Proxy (Fiddler2).

VC: 6.0.7, Build: 21758, BuildDate: 2012-02-23 13:47:01, Trial License.

I'm running a http proxy, Fiddler2, on my Win 7 dev machine and I have this proxy listening on the default

I created a VC job, also dev box local client and server, and added a WebService/WCF task. I setup the web service and execute it and it works just fine hitting our clients sandbox.

I then clicked the Proxy button for this new service and selected a HTTP proxy and put in the address ( and port(8888) of my Fiddler2 instance and run the step and it will not hit the proxy but hits the clients web service.

I verify the proxy is working by using browsers and set SoapUI to use the same proxy settings and push out service requests and I see the requests being logged in Fiddler but the VC step does not do that.

I then thought it might be a Fiddler issue so I added a fiddler script to force a break point on any trapped requests going to that client through my proxy.
if(oSession.HostnameIs("Redacted_Client_Uri")) {
oSession.oFlags["x-breakrequest"] = "ForceBreak";
This breaks when I use any browser, soapui, etc that hits my proxy but VC never triggers this.

I've tried listening on different port numbers and that has had no luck, each time I verify other applications packets are captured.

Can someone please indicate what it is I might be missing to get a WebService task to use a Http Proxy for debugging?

Thanks for your time
Forum information
I downloaded Fiddler2.

I set the proxy settings and when I ran the Web service Task it showed up up in Fiddler UI.

How do I know if the proxy is used in Fiddler? It looks like all my connections show up.
Please like  VisualCron on facebook!
Thank you for your reply and the time you have put in.

Can you please tell me how you are running the WebService? I am right clicking on it and selecting 'Run task Google Headquarters Elevation'

But I am still unable to get VC to use my http proxy, I just rebooted, turned off all Firewalls, Virus Scanners and still nothing and created a new job/task.

I found a free web service, to help debugging, from the USGS for finding elevation at 
I created a new job, pointed it there and used the
getElevation method.
I entered the Long/Lat of Google Headquarters to verify the service is working.
Y Value 37.423269,X Value -122.082667, Elevation_Units: FEET

Added a new job with one task Webservice/WCF and it works fine and pulls back the data.

I have fiddler on 8888 working fine for all requests from other tools and browsers..and set VC by clicking the task, Webservice/WCF Execute/Proxy and selecting HTTP Proxy 8888 no credentials entered, nothing checked.

Still same, nothing logged in my proxy.
Can you perhaps share some info about your setup? or if you have something changed in Fiddler to use a different port?

Normally I'd just be done with it but I will have to have whatever automation tool that I choose route through a company proxy that handles auditing of specific web service usages.

Or if you have some debug flag in VC that has some 'verbose' type setting so I can let it log all data and inspect/set http headers I can skip Fiddler for this.

Thanks again for all of your help,
I am not familiar of how to use Fiddler2. I just reported what I saw. I do not know if it intercepts the calls or not. I did only use default settings.

How do I know if using the proxy or not? I mean, it probably does for both me and you otherwise we would get serious errors. What proves that the proxy is not used?
Please like  VisualCron on facebook!
Scroll to Top