Community forum

Please note that VisualCron support is not actively monitoring this community forum. Please use our contact page for contacting the VisualCron support directly.

After upgrading our VC from 8.0.4 to 8.1.2, an FTPS connection that we use frequently will no longer connect. It now errors out with the message "Server cannot perform SSL/TLS negotiation" The server is a government FTP site that requires FTPS implicit connections on port 990.

I get the same error when I use VC's Connection Explorer. I've tried a brute force test for the connection, but it came up with nothing. The log_server file shows this:

8/10/2016 5:00:11 PM Err Unhandled FTP login error: SBSimpleFTPS.EElFTPSError: Server cannot perform SSL/TLS negotiation
at VisualCronService.ConnectionHandlerClass.Connect(ConnectionClass cc, Boolean OpenConnection, VariableReplacerClass variableReplacer, Boolean bolRaiseErrors) in C:\sourcefiles\code\VisualCronService\Jobs\ConnectionHandler\clsConnectionHandler.vb:line 726

I can connect and transfer files with FileZilla just fine. Here's a snippet of FileZilla's log showing the TLS negotiation:

07:35:02 Status: Connecting to
07:35:02 Status: Connection established, initializing TLS...
07:35:02 Trace: TLS Handshake successful
07:35:02 Trace: Protocol: TLS1.2, Key exchange: ECDHE-RSA, Cipher: AES-256-CBC, MAC: SHA384
07:35:02 Status: Verifying certificate...
07:35:02 Status: TLS connection established, waiting for welcome message...

Is there anything else I can check?
Forum information
Try going to the Connection and check only TLS version 1.2.
Please like  VisualCron on facebook!
Originally Posted by: Support 

Try going to the Connection and check only TLS version 1.2.

That got it working. Thank you!
Scroll to Top