Community forum

Please note that VisualCron support is not actively monitoring this community forum. Please use our contact page for contacting the VisualCron support directly.

I'm trying to use remote execute to run a .exe file that I just created which queries CDOEXM (data objects for exchange) and gathers information on the databases and then sends a report via email.

When run from VisualCron, I get a CDO error message:

"Exchange Server has not been installed on this machine.

ID no: c103222c
Microsoft CDO for Exchange Management"

When I log in as the user which the exe is to run as, the output is as expected. This leads me to believe it could be an issue with loading the complete profile of the user when the exe is run from VisualCron.

I have VisualCron running the exe on the Exchange server itself, so I know Exchange is installed.

I am including the .cs file I used to build the program, if it helps.

File Attachment(s):
program_sanit.txt (4kb) downloaded 55 time(s).
Forum information
Remote execute is very limited. Why can't you do a local Execute "with profile"? I mean, that CDOEXM must support remote connection right?
Please like  VisualCron on facebook!
I would, but the VC server is running on 2008 which does not support the 2003 Exchange Tools.

I think I will try a psexec using local execute and see if that works.
Yes, that would give you some more flexibility. We will implement Exchange Tasks to retrieve exchange information in a near future version.
Please like  VisualCron on facebook!
I think I found part of the problem, and it was in the help description of psexec.exe (I was running into the same error as before, exchange not installed).

If you omit a user name the process will run in the context of your
account on the remote system, but will not have access to network
resources (because it is impersonating). Specify a valid user name
in the Domain\User syntax if the remote process requires access
to network resources or to run in a different account. Note that
the password is transmitted in clear text to the remote system.

Since Exchange integrates with LDAP/AD/etc, it required a username and password instead of impersonation. After that it worked fine.
Great, thanks for the information.
Please like  VisualCron on facebook!
Scroll to Top