Please note that VisualCron support is not actively monitoring this community forum. Please use our contact page for contacting the VisualCron support directly.

  •  BobJ
  • Paid support Topic Starter
when I select functions, like all of the "string" functions, I see the error shown below. If I attempt to use String.Substring, I don't get the value expected based on the command - the error is returned instead. First noticed when I tried to format a value that I would then use with the "PDF add footer/header" and I was seeing this error instead of the substring value I was going for.

TranslateVariables->Unhandled error: Could not load file or assembly 'GoogleTranslateAPI, Version=, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified. on string: {STRING(Right|TestString1|4)}
Forum information
Johan Noyez

Are you running version 9.9.0? We had the same problem and had to downgrade to 9.8.5, but this version is also not stable for us, many hang-ups.

Any word on this?

I had to remind myself that for several years my team used Visualcron almost exclusively to schedule calls to other executables with no use of variables or complex controls, and would barely have been affected by this at all, in order to stop thinking that an issue this severe seemed like an obvious call for profuse apologies and withdrawing the affected release until a hotfix was ready. I still find it concerning that no official comment seems to have been made and that I couldn't clearly identify a fix in the 9.9.5 release notes.

I thought about trying to check it out myself in either a Windows snapshot or with a VM snapshot of our server to fall back on, especially given that the error suggested maybe a DLL was simply not copied to the correct directory, but if I recall correctly I only got as far as verifying that the DLL was at least in the installer before I had to go work on something else.
For the record, despite the utter lack of fanfare, this does seem to be fixed in 9.9.5.

https://www.visualcron.c...ts&m=41032#post41032  is still a thing, though, for those who might care.
Ah. Well, at least now it's only affecting the thing that should actually be using it.

This looks to me like a combination of package management failing and the feature not actually being ready. I went to Nuget and downloaded that DLL, dropped it in the program folder, and restarted the client, and it gave me a similar error indicating it was looking for a different version of Google.Protobuf from the one provided. Rinse and repeat, missing Google.Api.Gax.Grpc. Rinse and repeat again...and the error is now "Could not find file 'C:\Program Files (x86)\VisualCron\JSONPath'. on string:..."

Give it a filename that exists, and it complains about either finding a null (if the file is empty) or the first character being unexpected (for the handful of things I tried), but...I can't fathom why it's looking for a file for this in the first place, let alone guess what it expects to find in it.

Plus, "[FEATURE] Client/Server: Translation->Added translation to many languages (VC-2050)" appears in the changes so far for the current beta, and notably not in any recent changelogs for released versions.

I think maybe a partially-completed feature was released by accident in a non-working state. And the issue in 9.9.0 might have been that the assembly reference was mistakenly added in almost all the variable code paths, instead of only the one where it was going to be used. Hard to say for sure.
Luke Saunders
I saw this same issue when upgrading from 9.8.5 to 9.9.0.

Variable 'EventTrackerFileCount' was updated to: 'TranslateVariables->Unhandled error: Could not load file or assembly 'GoogleTranslateAPI, Version=, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified. on string: {STRING(RowCount|\\ftp01\Users\PLnccET\EET.Ent20211025103554.txt

Is this resolved in 9.9.5?
I think as far as Thomas and I could tell, the only place it still occurs in 9.9.5 is if you actually try to use the translate Variables (and what it can't find has changed slightly there).
Scroll to Top