[8.2.7] API development - VisualCron - Forum

Community forum

Bogle
  •  Bogle
  • No customer Topic Starter
2020-12-23T10:48:26Z
I want to experiment with the .NET API at my company that has v. 8.2.7. Do I need that version installed locally? Where can I get hold of it?
Bogle
  •  Bogle
  • No customer Topic Starter
2021-01-25T15:12:51Z
I've installed the v.8.2.7 client on my dev machine and I can use the API but it can't connect to the server. The reason is, I believe, that I require .NET Framework v.2.0 on my dev machine, which I don't currently have installed. So, I could install that or I could install the latest VisualCron client which, I think, works with .NET Framework v.4.8. I worry that the VisualCron API will be too different, though.

Which is best: install the .NET Framework v.2.0? Or install the latest client to use against the older server API?

The exception I'm seeing:
$Global:Server = $Client.Connect($conn);
| ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
| Exception calling "Connect" with "1" argument(s): "Could not load type 'System.ServiceModel.ServiceBehaviorAttribute' from assembly
| 'System.ServiceModel, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'."
Scroll to Top